LibreOffice inserts page breaks between subdocuments into a master document ODM

I created master document (ODM) in LibreOffice.

I inserted several subdocuments into it.

LibreOffice inserted page breaks between text of subdocuments.

I removed all page breaks and saved master document.

When I open master document LO suggests me to update links (this is mandatory step) and I see all page breaks again.

How can I remove page breaks between subdocuments?

Edit your question to provide OS name and LO version. Are there page breaks in the subdocuments? Which paragraph styles do you use in the master and subs? Are your documents based on a template?

Don’t use “Add answer” which is reserved for solutions in a Question & Answer site like this one.

I found the solution.

If you want to remove page break before specific subdocument you need edit the subdocument, select the first line and click the right mouse button. In the appeared context menu select the menu paragraph and then select the top line “Paragraph…”.
You will see new Window with Paragraph properties. You may check that the window has name with only one word “Paragraph”. In other case you will see the name of specific style: for example if you select Paragraph → Edit style - the window will have the name for example “Paragraph Style: Heading 2”.
In the window with “Paragraph” properties you will see “Text Flow” tab with “Breaks Insert=ON” checkbox.
Deselect checkbox, confirm changes and save subdocument.

Then in the ODM select “Update Selection” in Navigator window on changed document. And you will see that changed document will follow right after previous document/text without page break.

The point in the master document is that the MD styles will override the styles having the same name in the sub-documents.

Thus, you don’t have to change the sub-docs, you merely have to do what you did in the master doc only.