Libreoffice installs but won't open on windows 10

I installed libre office onto my windows 10 computer with 64 bit. It appears to have installed but when I attempt to open it it’s just a blank white box and then times out. I have uninstalled and reinstalled three times. I also tried an older version of Libreoffice with the same results. Running as administrator did not help. Any ideas?

Make sure the file protection/ransomware part of your firewall is not blocking it. That’s the only thing I can think of off the top of my head.

You may try to refresh the profile or disable OpenGL by running Libreoffice with --safe-mode from the command line.

Example (type the following in the command line):

"C:\Program Files\Libreoffice\program\soffice" --safe-mode

In my case, I disabled OpenGL and it worked.

I see most of the comments come from 2018. I am not sure if my solution would help someone but it was as follow:

As long as you are using Windows 10:

In the Windows Menu List “LibreOffice”, select the option "Disable Hardware Acceleration (OpenGL, OpenCL) in “Configure”

That is it. Hopefully works for you.


Robert B

I went into properties and denied the system access, only allowing myself as administrator access to Libra Office Calc (I assume this works for others in Libra Group but I only use calc). Now I click on the Libra Office calc shortcut I have on my desktop and Libra Office calc opens straight away.

Have a look at:

General Installation Issues (Windows)