LibreOffice Math: Missing Symbols

Hi:

I’m using libreoffice-math-7.0.3.1-1.fc33.x86_64 in Fedora 33. While editing formulas I find a problem with symbols in the Math editor. Specially annoying is the minus sign not represented neither in the operators menu or in the final formula rendering:

The two Abundancia¹¹ formulas uses different fonts configuration, the first Times New Roman:

I don’t really know what’s happening neither how to fix it.

Thanks.
and the second Liberation Serif:

PD: added an example file: example.odt

You’d better share a sample file. And why not use a real minus (U + 2212) instead of a hyphen?

@gabix done!

Fine in LO 7.0.1.2 / Windows 7 with Liberation Serif or Times New Roman. A Fedora problem?

Fine in LibreOffice 6.4.6.2 on Ubuntu 20. You may have a problem with the font used for the mathematical operators.

How can I know which is the operators font? I’ve tried changing all in the fonts menu, as explained without success.

Check libreoffice-opensymbol-fonts-7.0.3.1-1.fc33.noarch correctly installed.

Should contain;

user@system:> rpm -ql libreoffice-opensymbol-fonts-7.0.3.1-1.fc33.noarch
/usr/share/doc/libreoffice-opensymbol-fonts
/usr/share/doc/libreoffice-opensymbol-fonts/LICENSE
/usr/share/fonts/opensymbol
/usr/share/fonts/opensymbol/opens___.ttf

On my Fedora 33 using distro packages for LibreOffice 7.0.3.1, there is no problem with your sample file.

It isn’t listed, as far as I can see. Make sure that you have the OpenSymbol font. Also check out the other panels - like relational operators, set operators etc. If some of the more complex characters are missing, you know that you miss an important font.

@floris_v

How do you know that it isn’t listed? The fonts shown in the screenshots got nothing to do with the problem (imo).

Works fine Fedora 33, LO 7.0.3.1.

May be a font problem. Times New Roman is a Windows font. Consequently, needs a substitution. If you forced manually a faulty substitution, this might be the cause. Try to erase it to let LO manage it on itself.

You can download the MS Core Fonts, that includes Times New Roman and some other basic fonts.

Yes, Times New Roman is a font supplied with Windows. However, the Liberation font family is not, but, as the asker claims, the problem is with those fonts, too.

I’d suggest to try some other fonts such as DejaVu fonts or, say, Linux Libertine. They are available in many distros, should be in Fedora as well. And, again, try to input a real minus, see above. Here is some code:

Abundancia¹¹= {100 cdot ¹⁰B + 100 cdot ¹¹B − 100} over {¹⁰B + ¹¹B}

@olea: out of curiosity, why do you use Unicode superscript symbols instead of B lsup 10?

  1. ¹⁰B renders badly compared to lsup formatting directive
  2. ¹⁰B is considered a single symbol and is formatted as a single Variable, i.e. all italics, instead of two parts, variable B formatted Variables and superscript 10 formatted Numbers (not italic).

@ajlittoz I did because I though it was appropriate :slight_smile:

Thank you for your suggestion :slight_smile:

After following your comments I found I had some mismatch with Time New Roman configuration: it was installed but for some reason disabled, probably by me of the past.

Also, following your suggestions I’ve checked opensymbol font (it was installed) and installed Linux Libertine.

I’m really thankful for your help :slight_smile: