LibreOffice no longer recognises foreign languages

Upon trying to open a file with non-Latin characters in its name, LibreOffice produces the following error - The operation on /home/user/Desktop/???????????????? ?'.?.docx was started with an invalid parameter. (example). Trying to paste non-Latin characters into the document from elsewhere results in text being replaced by random characters (example - онраырпеаÑречрт). However, typing in a different language appears to be unaffected, as is saving a document containing non-English text.

Starting up in Safe Mode doesn’t affect the issue. I have also replaced libreoffice-still with libreoffice-fresh, but the problem still persists.

This could be related to a recent kernel update; however, no other applications seem to exhibit this behavior.

What is your locale?

trying to open a file


Here’s my locale printout:

locale: Cannot set LC_CTYPE to default locale: No such file or directory locale: Cannot set LC_MESSAGES to default locale: No such file or directory locale: Cannot set LC_ALL to default locale: No such file or directory LANG=en_001.UTF-8 LC_CTYPE="en_001.UTF-8" LC_NUMERIC=en_001.UTF-8 LC_TIME=en_GB.UTF-8 LC_COLLATE="en_001.UTF-8" LC_MONETARY=en_001.UTF-8 LC_MESSAGES="en_001.UTF-8" LC_PAPER="en_001.UTF-8" LC_NAME="en_001.UTF-8" LC_ADDRESS="en_001.UTF-8" LC_TELEPHONE="en_001.UTF-8" LC_MEASUREMENT=en_001.UTF-8 LC_IDENTIFICATION="en_001.UTF-8" LC_ALL=

I also have ru_RU and be_BY packages installed, as well as Russian and Belarusian packages for libreoffice-fresh.

As for opening files, the above error is produced when accessing a file either through GUI or using the libreoffice -o command.

I would try to
export LANG=ru_RU.UTF-8
export LANG=be_BY.UTF-8

Unfortunately, that didn’t work, but attempting to open a file via terminal now displays this:

qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 1179, resource id: 14680290, major code: 40 (TranslateCoords), minor code: 0

qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 1296, resource id: 14680295, major code: 40 (TranslateCoords), minor code: 0

It looks like a Qt issue. Hardly anything that you can fix in / with LibreOffice.

Follow-up: here’s a bug report that I have found:

Quite fresh.

Actually, I’ve started having the same problem with other apps, like Vim, so this is probably caused by the kernel being updated (5.8.18-1-MANJARO to 5.9.3-1-MANJARO). I initially thought this was a singular case because every other app I checked prior had worked just fine. Still, thank you for your suggestions.

It looks as if you have a problem with setting up the computer system to use Unicode. Has it always given this problem or have you changed system settings? What operating system are you using and language? Do you have a problem opening Writer and creating text?

LibreOffice and the Internet are based around Unicode, the UTF-8 setting of Unicode.
The problem with your cut / paste giving text such as онра is that the original Unicode text is being pasted with an “older” local text such as US-ASCII or more likely ISO-8859-5 as used in older Russian systems. I assume it is ISO-8859-5 as this could give € characters when miss-translating UTF-8 Unicode Characters.

Have you set up LibreOffice to understand Russian? On my Linux English(GB) system TOOLS >OPTIONS >LANGUAGE SETTINGS >LANGUAGES >RUSSIAN (or >BELARUSIAN)

I think the same system setup problem is also causing your file opening problem. Sorry I do not have a definite cause, but I hope this might help.


Total nonsense. LGC languages have nothing to do with complex text layout.