LibreOffice Not Recognizing/Accessing User Fonts in OSX

I just downloaded and installed LibreOffice (v. for the first time on my new MacBook Air (running Sierra 10.12.4). Had never used LO before, but had recently started using LibreCAD and really liked it, and thought I would make the switch to an open-source office suite, which I had been thinking about doing for some time. From the very little I’ve seen it looks good and I’d really prefer it to Office or Pages.

After installing LO and launching and opening a blank Writer doc, I quickly discovered that LO/Writer was not recognizing or accessing my active/enabled User fonts, which I manage in Font Book. I used to design and lay out books so I have a considerable collection of typefaces; I used to manage them in Extensis Suitcase Fusion, but switched to Font Book when I no longer needed more robust font management. Thus I am not new to problems of font management in different applications. But this problem continues to stump me after trying a number of things and reading through the forum here.

LO is only displaying my active or enabled “Computer” fonts, as opposed to “User” fonts, which are those added to FB by me. Most of my User fonts are Postscript fonts, though a few might be Opentype, but from what I’ve read that should not be a problem anymore as Libre now supports OTF. I can enable and disable the Computer fonts in Font Book, and they subsequently activate and deactivate correctly and accordingly in LO. (Of course, you can only disable certain of the Computer fonts; those fonts that are root System fonts (Macintosh HD/System/Library/Fonts) cannot be “managed” as such.) So the fonts that live at ~/System/Library/Fonts and ~/Library/Fonts–along with LO’s own fonts like Liberation Sans and Linux Libertine–are functioning fine within LO. But not my User fonts from ~/User/Library/Fonts. By the way I cannot located any of the Libre fonts on my HD.

I’ve tried quitting and restarting LO; quitting all and restarting the computer; and ditching LO and reinstalling it. I also dumped preferences “” and “” and cleared all font cache files, as apparently Sierra seems to be having some of its own problems with fonts working in some and not other applications, because of how the OS and apps are using Unicode.

As mentioned I’ve gone through quite a bit of looking for solutions, but didn’t find anything similar enough to extrapolate a fix. There are also a few aspects to the responses that I confess to not understanding, but I don’t think I’m missing anything germane therein.

Has anyone else experienced this in OS X and know what’s going on? I’d really like to use LibreOffice but need to be able to access my fonts. Many thanks!

Have a similar problem, with a custom font I installed (OSX 10.11.6).
Trying to resolve another font-related problem (have an ask question open at the moment already), I tried upgrading to version 5.3, to see if by chance it solved my problem.
As a result, version 5.3 didn’t see my custom font at all.
It is regularly installed and validated by OSX, but had to go back to LO 5.2.6 for using my font again…

After reading around different forums online–and in the end I think the suggestion for the fix came actually from a thread about another open-source office product–I dumped the 5.3.2 “fresh” version and installed the 5.2.7 “mature” edition. Which seems to have solved the problem completely. I actually read that and implemented the fix just before I saw e_del’s answer above, which reports doing the same thing with success. I don’t even know what the differences between the two versions are, so I have no idea what, if anything, I’m really missing. But when downloading LO for the first time I went with the fresh version as I am definitely not an enterprise user. Just a little snapshot of the major differences btw the two versions on the download page would probably be nice–including, perhaps, a note about font-management stability. Thanks, e_del and Libre forum.

It seems this can be related to the adoption of the Harfbuzz engine.

Sorry if this is not the right place to ask: but how could we support the addition of Type 1 fonts to Harfbuzz? I’m not a developer, and would be willing to donate to support the development of this feature.

1 Like