LibreOffice Not Responding

While using LibreOffice 4.0.2 (Calc and Writer both) it will unexpectedly go to “Not Responding” after performing any number of commands (i.e., print preview, formatting, printing) and I can’t even kill it using the Windows Task Manager. I am running Windows 7, Service Pack 1. At that point I need to reboot to kill LibreOffice. I have tried to reset the User Profile (using the instructions in, but this only worked for a short period of time and my issue reoccurs. Any suggestions on what I can do to keep LibreOffice from going to “Not Responding” or to be able to kill it if it does?

I am running Java 6 Standard Edition, Update 30. I have not looked into the backtrace instructions, but I can…

The three commands that have most recently caused LibreOffice to move to “Not Responding” are Print Preview (in both calc and writer), Print (again, both calc and writer) and a right click on a cell in calc to do formatting. The only other things I have running are Windows Live Mail, Internet Explorer and Windows Explorer.

Waiting because it is just slow is not the issue. I have let the circle implying something might be happening go for over an hour and nothing happens. It is definitely not the normal slow processing. And it indicates that it is “Not Responding” in the Title Bar.

Telling us the question is answered correctly without providing a link to that correct answer is not helpful.

There are backtrace instructions for the Windows platform here. This is an advanced option, but it may tell you more about what is going on. I doubt this is related, but which version of Java do you have installed?

EDIT: Thanks for the addition information. Java 6 Update 30 is quite old (2011-12-12). I would try updating to at least Java 6 Update 45 (2013-04-16) and see if that makes any difference, before looking at anything else.

I had similar problem. It may be in your case too…

  1. Unplug network cable (for safety reasons).
  2. Stop all of the anti-*** security software you have installed antivirus/antispyware/firewall etc software that could temporally scan LibreOffice actions and make it non-responding. Note: Some of the anti-programs when closing it down, only closes GUI part of software, but background processes part of software is still running. So make sure you really shut-down this software.
  3. Retest LibreOffice actions. Does problem still appears? If no, then you know one of the anti-program is blocking your office suite. Try to determent which one and then add exceptions to exception lists of anti-program that is blocking LibreOffice.
  4. Start all of your anti-programs again with exceptions for LibreOffice.
  5. Plug network cable back
  6. Report to anti-program vendor the freezes that this program does to LibreOffice, so vendor can fix the problem.

I found this solution that resolved it for me, suggested on another site (sorry, I don’t remember where) where similar issue was posted and I decided to try it after exhausting all possibilities (antivirus, profile, different versions of Libre, graphics settings, libre settings, etc) suggested on my Windows 7 64bit OS:

Disable context indexing on the computer itself:

  1. Open Windows Explorer
  2. Right-click on the hard drive, select Properties
  3. UN-CHECK the Allow files on this drive to have contents indexed in addition to file properties
  4. Apply
  5. How long it takes to update seems to depend on amount of files on hard drive - took 20 minutes to update my
    disk which has about 600GB used on a 900+GB drive
  6. Rebooted
  7. Opened Writer, opened the file (has images and text, and issue of Not responding for 120+ seconds able to recreate on demand when select Save), added text and an image, saved.

And YES!! now Save completes immediately without long Not responding issue.

Hope this helps others.

Just wait, because it is slow.

Treat it differently, not like how you work with other Office.

Don’t really agree with this command. LibreOffice is just not freezing non-responding software, it must be some reason outside of LibreOffice, so some antivirus or some other software that creates non-respond state.

@LibreOfficeUser2 - Try to write down what the last actions in Calc and Writer you did and note which other applicaitons are running. This could help to get to the route cause.

I am having a similar problem. I created a document in LibreOffice. Used it multiple times, and then one day I can’t open it and LibreOffice won’t respond. I end up having to do a force quit. It has happened 3-4 times over the last few weeks. I’m on a Linux computer.