LibreOffice not showing certificate in "digitally sign" menu nor in the "View Certificates" menu. LibreOffice 5.2 on Linux Debian 9 with GNOME

I have received a .p12 certificate from my organization and successfully imported it into both Firefox and Thunderbird, and into seahorse. However it doesn’t show up in the list of certificates in Libreoffice. I checked the Tools > Options > Security > Certificate Path and it has both correct paths to my firefox and thunderbird profiles. I tried switching between the two and it doesn’t do a damn thing. Also I tried adding the path for seahorse’s storage, ~/.local/share/keyrings but it also doesn’t do anything. Tried rebooting the computer too. So how the heck can I sign a document using my certificate? Thanks