LibreOffice Portable File Association Problem

Using LibreOffice as a “portable app” under windows, how do you set up the proper file association?

Right click this link —>C:\fakepath\LibreOffice 1803.jpg click Save link as Change file extension from .jpg to .rar, Unrar it to get the .reg, Use writer to open the .reg and then CTRL+H and find all: D:\setups and D:\\setups and replace all D:\setups and D:\\setups respectively with your directory.

On my second drive D: i have a folder named setups where i keep all the software i might use in the future. I created the same folder structure as the Portable LibreOffice version so the installer will generate the correct registry path to files then used RegSeeker to export all registry entries with the name LibreOffice.

Note: I had to rar the file cause it was too big to upload it (1.750 KB).

Note2: I couldn’t import the .reg in Windows 10 1709.

Note3: The path that should be kept the same with the portable version in order to export the registry keys is \LibreOfficePortable\App\libreoffice\.

Note4: After importing the .reg i noticed that Windows 10 ask me which program to use for .txt files so you ll have to reassociate .txt file types with notepad.


It’s not clear what that first URL is for – it is usually better to upload any files as attachments to your answer here. If you have solutions to other issues, ask the question you have a solution for, then post the “answer” as answer, like you have here. Thanks!

@david ah sorry i always forget that most forums have an attachment feature, will edit it out.
Edit: the site doesnt allow to attach *.reg files so…
Also as far as it concerns importing the .reg in Win 10 1709, 2 Microsoft Agents couldn’t help, also the community forums are filled with posts “Cannot import *.reg Error accessing the registry.” and those threads are locked… what ever that implies…

Hi - it always takes a bit of time to learn the ways of a new site. Thanks for persevering. The guidance for attaching disallowed file-types is given in the general help about attaching files to posts on the Document Foundation wiki. Hope that helps!

@dajare ah yes it is common logic to change file extension i missed that, even though i have done similar workarounds in the past.

Right-click on the file you want to open.
Select Open With
Select Choose default program
Select Browse and browse to and select the application.
Check the box Always use the selected program to open this kind of file
Click OK and you are done.

Do the same for other file types.

If this answered your question please check the checkmark at left.


@LibreTraining This works as well. too bad we cant have two 2 different acceptable answers.

Still, you can upvote the other answer.