LibreOffice "Save As" won't show "Flie Type" dropdown

I just installed Libre Office and the help pack and when I go to save a file, (Either one I’ve edited or a brand-new one) the “Save As” dialog, I cannot choose a File Type… (The dropdown is missing!) but the label is there, and if I resize the Save As dialog , it appears that the screen is not updated where the dropdown should be. (“Ghosts” of things like the “Cancel” button appear where it should be…) This also happens in the Export dialog… Clicking also Save or Cancel does nothing, (I did get it to save a new document once, but I don’t even think I could reproduce what I did to get it to do so, and it made an ODT file which is no good for sending out (resumes) to employers.) I have to click the X in the top right of the dialog to exit it, without saving… This problem occurs in ALL LibO products on this PC, but my main concern is Writer…

I am running a fairly clean XP SP3 install, and except for Microsoft Office Compatibility Pack & previous use of Open Office Portable there has been no software installed to handle Office documents… What’s going on???

I have already tried repair installs of both the help pack & LibO with no changes in what’s going on…

I have LibO Portable on another PC (works fine there) but when I ran the portable version on the PC with the problem above, the same problem happens…

I tried replacing the User Profile , but that didn’t fix the issue…

The PC is malware/virus free (as scanned by Security Essentials with the latest updates…)

I will attempt uninstalling the Help Pack & LibO and do a fresh install later… (Just to thoroughly test, I’ll also try with LibO Portable while everything is un-installed too.) Maybe tonight…

I might also un-install the Microsoft Office Compatibility Pack, later as it’s not going to be needed once I have LibO up & running…

Ok, I’ve found a work-around for it… I have enabled “Use Libre Office Dialogs” somewhere in the options. It would still be nice to know what’s gone wrong with the standard Windows API dialogs & fix it though, so feel free to be a knight in shining armor and chime in with the solution…

OP: @mkingsmill

That’s apparently Bug 74295 - UI: WinXP save dialog is broken if recent file combobox is turned off.

Please have a look at the comments/attachments on Bugzilla

(see also the duplicates fdo#75415, fdo#75682, and fdo#75695).

Maybe a temporary workaround:

Menu Tools → Options → LibreOffice → General

:ballot_box_with_check: Use LibreOffice dialogs (enabled)

Press OK

That’s it… (Hope they fix it soon.) Thanks!

I am running LibO on an XP/SP3 without the problems you report. I also run occasionally LibO portable versions without any problems. I assume that the “Microsoft Office Compatibility Pack”, which I don’t know, does not create a problem.

Therefore I am afraid that there is something wrong with your installation and/or the PC.

What would I do?

  • Test if a portable version runs: download from:
    if the portable runs, the indication is that there is a problem with your installation
  • Next, check the machine for viruses, malware, etc to be sure or make sure that the machine is clean.
  • Replace the User Profile; see
    if not successful:
  • Repair the installation - “Add & Remove Programs”-function in the control panel
    if not successful:
  • De-install all components of LibO and reinstall. I also might first back up my user profile
    By then the problem should be solved.

Please note that I am using the LibO dialogs and see also the answer of @manj_k