LibreOffice SDK 7.6 unoidl-write cannot start and gives error message (0xc000007b)

Good Morning all,

Hoping somebody can help me or at least point me in the right direction as I have searched on google about this error message for some time now and followed most advice ie installing C++ redist etc etc but no matter what I do the error still appears as below.
unoidl-write error message 0xc000007b_2

I will give a bit of history to help.

I first had LO installed and the corresponding SDK and idlc.exe (which I believe unoidl-write has replaced among others) worked as it generated the .urd file from my .idl file. I then upgraded/installed to LO x64 version and installed the corresponding SDK kit and this is when I first encountered the error message with unoidl-write “The application was unable to start correctly (0xc000007b). Click OK to close the application”.

After googling around it was suggested that there may be a mismatch between target processor and application ie x86 vs x64. I then uninstalled LO and installed the x86 version of LO (same version number) to match the SDK which afaics is only targeted to the x86 processor so at least they matched but alas no difference and same error message.

Some google results suggested it was to do with the MS c++ redist missing so I installed both (x86/x64) 2015 - 2022 but this still made no difference.

Below is my build.

Windows 7 x64 OS - service pack 1.
i3 x64 processor.
Both the x86 and x64 version of LO were running fine on my system and the x86 still is.

I know I need to add parameters to unoidl-write which I did but the same error message appeared :angry:.

My apologies if I should have added this to another thread ie like (How to use unoidl-write to replace idlc/regmerge example but this was back in 2023 and didn’t really cover mine query afaiks added to which I have just joined and this is my first post :innocent:.

Any help will be welcome.
Thank you

No, that is incorrect - SDK targets whatever architecture is supported.
Could you please check your system logs (Computer ManagementEvent Viewer) for something relevant, appearing at the moment when the error is shown?

Hi Mike,

Thanks for the speedy reply :smile:.

Yes, you are right, my apologies, I only saw the x86 version of the SDK which I downloaded but have since looked again and seen the x86-64 version.

I have reproduced the error 3 times and on each occasion the same error is logged in the event viewer (snapshot loaded) but nothing else and it doesn’t really give much more information that the error message itself.

Any ideas? :slight_smile:

Many thanks

whoops, snapshot is now loaded… :slight_smile:

It’s very strange. I have tested just now, with both LibreOffice_7.6.4.1_Win_x86_sdk.msi and LibreOffice_7.6.4.1_Win_x86-64_sdk.msi. Works here…

Which CPU do you have? It sounds as if somehow the binary was compiled e.g. with AVX or AVX2 support, while our supported CPU baseline is SSE2. It happened with main program executable, and was quickly caught and fixed - because of wide use and testing. But with SDK, which is used not that often, it’s no wonder that a similar problem could go unnoticed… ?

Hi Mike,

My CPU is as follows,

SS Laptop Processor

Yep, I know, old and probably on its last legs but I cannot part with it… :grin:

Not sure if it helps but as I said, I could run the old version of idlc, cppumaker and I think regmerge as well (not sure) before with SDK ( which was the x64 version as was LO.

Many thanks

HI Mike,

Just a bit more info.

I have tried all exe’s in the sdk\bin folder and they all reported the same error message except for unoapploader which instead generated an text error log called “unoapploader-error.log” with the following error message “Error: cannot create process!”.

Not sure if this will help in any way…


@sberg and @cloph Hi! Could you please take a look at this, to see if it’s possible that SDK gets compiled with wrong CPU / instruction set support?

@BTW_JustOneMoreThing - could you please test with:; It could happen that it’s already fixed.

Hi Mike,

So I installed both and after 24.2.0 then of course the corresponding SDK’s and all .exe in the bin folder worked.

Strangely however, I reinstalled the original and the SDK to check and guess what…unoidl-write worked so I am not sure what was happening there before. The only thing that was strange was after uninstalling there was a lock on the program folder and I was denied access which I wasn’t before. Changing the security levels didn’t help.

Once the newer version was installed the access was fine.

Thanks for all your help and sorry if this was a wild goose chase :).