LibreOffice Shows as Startpage in KDE panel under all circumstances

Ever since I began using Fedora with KDE, any time I use any LibreOffice application the icon on the panel will be the generic “LibreOffice” icon for the Breeze theme, and on hover the window will always be identified as a “LibreOffice Start Center” application even though the application is actually an open document. This happens for all documents in all applications, including Writer and Draw. I am running Fedora 37, KDE Plasma 5.27.2, and LibreOffice, and the LibreOffice I have is the one that comes with Fedora and is updated through its repositories rather than downloaded directly from LibreOffice’s website.

I have the same configuration and everything is fine. Could you explain “Ever since I began using Fedora with KDE”? Does it mean you have switched from, say, Gnome to KDE Plasma in some non-destructive way, like having a separate /home partition which was handed over from your previous installation? In this case, some setting in your ~/.config or ~/.local may have caused this mishap.

The only occurrence of “LO Start Center” here is for application/vnd.openofficeorg.extension with extension .oxt, i.e. for LO extensions. You can check with System Settings, Customization section, Applications>File associations. See if the LO Start Center has lurked into the other application/ If this is the case, you can safely remove this application from the list (provided there is the correct one too).

The Fedora installation I have is fresh, what I meant was that when I got a new computer I installed Fedora instead of Kubuntu which was my previous daily driver. I’m going to try to attach a screenshot to this reply of what happens with the panel.

Sorry, here’s a better screenshot that actually shows the “start center” thing, since it disappears as soon as I hit print screen

Your screenshot doesn’t show the Start Center window but an open document in Writer (“ribbon” UI) with the KDE “taskbar” at left of screen.

It is likely you launched first LO Start Center which installed its icon in the task bar. However, as soon as you open a document, the icon should have changed for the one corresponding to the present document.

Unless … Have you manually inserted the LO Start Center icon in the taskbar to be used as a shortcut to quickly launch it? I don’t do it because the Start Center contents is “dynamic” (only the most recently opened documents) and usually the document I want won’t be in the list. I prefer to double-click on a document icon. In case I want to create a new document without opening another one first, I use the Fedora menu>Office>the LO component or Fedora menu>Recent Applications>…

I uploaded a second picture that has the (faded) window flyout because I didn’t realize that it disappears the second you take a screenshot. What happens is when I launch LibreOffice by opening a document from Dolphin, the correct application’s icon appears in the panel until the application finishes loading, upon which the “Writer” icon is replaced with the generic icon.