Libreoffice sidebar width too large, impossible docking navigator

These days, due to a sudden crash of my notebook, I had to configure a very similar one, going from Ubuntu 16.04 to Ubuntu 22.04 and from LO snap to LO canonical, where the Shell function finally works correctly

Unfortunately, since I no longer have the old notebook in parallel, I have to go from memory. But I remember perfectly that

  1. the font-size of the sidebar and navigator text was much smaller and therefore took up less space
  2. I was able to resize the sidebar much more than now
  3. (most importantly), I had no problem restoring the docking of the navigator and sidebar on the same side, on the right, in the same column, distributing the vertical space by dragging the dividing line and resizing the width as desired, certainly a lot more than before

In this post by @Lupp [Solved] Is it possible to have 2 sidebars in Writer document? - #3 by Lupp it is confirmed that point 3 was supported in version, but I was able to do it until I crashed both with 6.2.8 canonical and with the various 7.x snap versions that I used in parallel

Since I switched to the new Ubuntu and the LO canonical the docking on the sidebar works, but with a width that greatly limits the use of the application (writer), especially with the styles and even worse with the navigator inside the sidebar, and it is impossible to reduce them (while you can with the gallery), see image

Docking the navigator is impossible, that gray rectangular outline that signaled, moving the navigator to the extremes, when the mouse was released for docking, never appears.
Furthermore, the navigator is signaled to me as a separate document (if I open a single writer or calc document, when the navigator opens, it signals the navigator to me as a second open window, which I don’t remember happening before)
If I approach the navigator to the extremes it becomes as large as the entire working window.
The usual techniques like CTRL+SHIFT+F10 or CTRL+double click on free or gray areas of the navigator don’t work
When the navigator approaches the edges, it expands to occupy all or a good part of the LO window, but overlapping the previous content, thus covering it
In addition, the docking/undocking techniques no longer work both in the development toos panel in writer and in the debug panel, at the bottom, where the variables are displayed in the IDE
Before upgrading to LO 7.5, the technician who configured my machine had put me on 7.3
When in doubt, I first tried to reset the profile, then I uninstalled everything, using the purge, then I reinstalled from scratch: the problem persists
I’ve also read about other similar cases here, but I haven’t seen a solution. I suspect it could be an internal LO setting or an OS problem with windows, but I don’t understand which
What can I do ? As it stands it’s just hard to work with

Ubuntu 22.04, LO canonical

it could be for this reason ?

Is there at least a way to reduce the font size of the text characters in the sidebar?
Perhaps this would allow the width of the sidebar to be reduced

Thanks to the intuition of an Italian user in an Italian forum (not related to ask.libreoffice Italian version) I solved the problem
As I suspected, the problem was related to the graphics management of the operating system, in my case Ubuntu 22.04, and in particular to wayland.
Switching from wayland to xorg during login solved the problem immediately.
It seems that wayland can also give similar problems with other applications and I do not exclude that the one I have had is not the only one.
Now both the docking of the navigator and the vertical division between navigator and sidebar of the column occupied by the sidebar and, with minimal problems, also the reduction of the width of the sidebar works