Libreoffice stopped saving files

Today, 18 December 2020, I noticed that the last save of many frequently used libreofficecalc spreadsheets and Writer documents had not been saved since 12 Dec 2020, although I use these files many times a day and save frequently. Is there any way to recover the more recent files? I have tried data recovery (Recuva), Wise and other searches with no success but it looks like I will have to try and reconstruct those files, as it appears that the save function did not work, and there were no error messages, which is why I did not realize the data was not getting saved.
I am using libreoffice and am reluctant to upgrade to version 7 because I tried the first release of version 7 and I was unable to use the program until I reverted back to version 6.4.
I am using Windows 10 release 2004

I took the 12 Dec files and put them on a flash drive and they updated fine. I check-disked my hard drive where they were originally stored and Checkdisk found no errors. My many backups did not help because they were only backups of unsaved files.

I did go into safe mode and reset the user profile and then tried putting the files on another drive and was able to save them.

I have given up hope of recovering the up to date files, since it looks like none of them were up to date, but can anyone help explain what happened and what I can do (besides verifying the saves) to avoid this in the future so at least I get a warning of some type when the files do not save?

Going into safe mode and resetting the user profile seems to have worked as I am now able to save files as often as necessaey. I would still like to know if this could have been caused by something I did wrong?

Update: I just discovered that when the files are autosaved, that save is not reflected in the file data in Explorer, but when I click the “Save” button in the program, the time and/or date changes in File Explorer. Shouldn’t the Autosave function cause the date/time to change?

I am pleased that you have solved the problem.

Following one of the many recent Windows updates I had to reset my user profile, although for a different problem. It might have been something I did but I suspect the update. They are often installed while I am working but seem to leave the computer in an unreliable state. As soon as I see a request to restart, I do restart but the damage might have already been done. Cheers, Al

Thank ou. I do keep both windows and other programs as up to date as possible, which is apparently not always the way to go. Appreciate the response.

AutoSave isn’t what you appear to think it is; it is in fact called Save AutoRecovery Information and saves the information that allows LO to recover your open documents if LO is terminated unexpectedly. It DOES NOT replace a normal save, either via Ctrl+S, File | Save or the save icon on your toolbar.

Thanks for the enlightenment. Now I knoiw I will have to check File Explorer to be sure that I don’t encounter a repeat.

You should be happy to know that your anti-ransomware (in your anti-virus) has been working silently in the background to prevent you altering your existing files.

If you don’t have a third party anti-virus then you have Windows Defender. I suspect you probably have a third party anti-virus but I am guessing. Your best bet is to add LO (and any other apps you use) to the list of allowed apps in the Av settings.

Allow LibreOffice access to Defender controlled folder

The below numbered list is from Use the Windows Defender Security app to allow specific apps

  1. Open the Windows Security by
    selecting the shield icon in the
    task bar or searching the start menu
    for Defender.
  2. Select the Virus & threat
    tile (or the shield
    icon on the left menu bar) and then
    select Ransomware protection.
  3. Under the Controlled folder
    section, select Allow an
    app through Controlled folder
  4. Select Add an allowed app and
    follow the prompts to add apps. You
    need to allow access to

Turn Off Defender

Select Start > Settings > Update & Security > Windows Security > Virus & threat protection.
Under Virus & threat protection settings, select Manage settings.
Under Controlled folder access, select Manage Controlled folder access.
Switch the Controlled folder access setting from On to Off.

3rd Party Anti-virus

If you do have a third party anti-virus go into settings and then look for something like anti-ransomware or folder protection. Have a look at the blocked apps list, if you see soffice.bin in there change it to Allowed (you might have to read AV help if not obvious). Otherwise go to the Allowed Apps setting and allow soffice.bin, this might not be easy so you might have to add the different LibreOffice executables (Calc, Writer, etc.) to the Allowed list. Note that 3rd party anti-virus might make files Read Only so you can create a new file but you can’t save it subsequently. Sometimes, you might need to reboot after allowing a program access.

Good luck, Al

Thanks for the info. I don’t understand why I would want to turn off Defender, as I had no issues adding soffice.bin to the authorized list.

Turn off is just an option, useful if you are testing to see what is causing a problem