LibreOffice suddenly doesn't open nor save documents containing Swedish characters åäö

I have used LibreOffice (on Ubuntu) for several years now and have always been able to save and open documents containing the Swedish Characters åäö. Suddenly I cannot open the documents I previously created with LibreOffice containing åäö, and I cannot create new documents with these characters. When trying to open a document containing åäö I get message: "The operation /home/xxx/…/åäö.odt was started with an invalid parameter. Trying to save a document with åäö it says I do not have permission to save (I can save the document in same place with other name). I do not have any issues with other programs on my machine, e.g., I can open the documents containing åäö with abiword. And as I pointed out allready, the documents containing åäö were created with LibreOffice previously, but now I cannot use them without changing name, which I really don’t want to. This is very frustrating, how can I solve this problem?

Some more input to clarify, as asked for:
The problem is filenames containing å, ä or ö (sorry I was unclear about that), I have no problem writing and saving the content as long as filename doesn’t contain the characters å, ä, and ö. Strange though LO is the only program I have the issue with, other programs let me have åäö in filenames and they are possible to list in Konsole. When I ran into the problem I updated LO with the following commands:
sudo add-apt-repository ppa:libreoffice/ppa
sudo apt update && sudo apt install libreoffice
It didn’t help at all :frowning:

From About LO
Version: / LibreOffice Community
Build ID: 40(Build:2)
CPU threads: 8; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: sv-SE (smj_SE.UTF-8); UI: en-US
Ubuntu package version: 1:7.4.1~rc2-0ubuntu0.20.04.1~lo1
Calc: threaded

Running Python (v 3.8.10)

import sys

what tells:


entered in terminal?

~$ locale

looks well… was there any ubuntu update|upgrade just before these Errors?
what tells from terminal:


and in the python-shell:

>>> import sys
>>> sys.getfilesystemencoding()

Do you use File → Open from LibreOffice? Or double-click in the file manager? Or open files from the terminal? Where does the problem appear?

I doesn’t matter which way I try to open the files, same result: The operation was started with an invalid parameter. Trying to save new the documents with name containing the letters å, ä, or ö give me permission denied.

Do you mean documents where the file names contain Swedisch characters?
Please call menu:Help>About LibreOffice… and click the button near version information. This copies all the info to the clipboard. Paste this info into your initial posting or into your next one. Did you install LO as a flatpak container?

1 Like

@Villeroy, how is this an “answer”?

It is a request for more information, surely?

1 Like

I don’t know. Must have happened by mistake. Since several weeks I try to always hit the comment button. Nobody has ever accused me for hitting the comment button even when the comment was an answer.

1 Like