Libreoffice taskbar icons showing generic grey-image for Version: (x64)

Updated to Libreoffice Version: (x64) Locale: en-ZA (en_ZA); UI-Language: en-ZA on Win10 Pro build 1909.
Did a complete uninstall of previous version, shutdown my PC and waited at least 10min. Started PC and installed Version: (x64). I’ve had this issue from about three versions back but just thought it was because I simply ran upgrades without uninstalling previous versions so this time I did the whole uninstall, shutdown and then did a “fresh” install. It’s just the taskbar icons for Writer and Calc that is the problem. It shows a generic icon image (grey-image) on the task bar. These icons in the start menu is fine. All the apps work and I have no issues with crashes or any other anomally. Mark Mclean posted a “solution” in 2018 where he suggested uninstall, shutdown, start and reinstall, but even that doesn’t work for me it seems. I can’t seem to find out what the problem is. Perhaps it’s a Win10 issue, I don’t know?

Did you ever try to reset your LibreOffice user profile? If a corrupt user profile (or you made a setting and you do not remember which one) is causing the problem, a reinstall would not help at all, since the reinstall won’t change or delete your personal profile in any way.

To reset the user profile perform:

  • Start LibreOffice
  • Start in Safe Mode using Help -> Restart in Safe Mode and confirm the restart using button: Restart
  • Archive your profile expanding Advanced (click on the word Advanced right above Help button) and click Archive User Profile button
  • Select option Reset to factory settings
  • Activate [x] Reset entire user profile
  • Click button Apply Changes and Restart

Hi, thanks for assisting. I tried your suggestion, unfortunately it didn’t work.
I now tried to pin writer and calc to the taskbar and initially when I did it straight from the Start Menu shortcuts it again placed a “generic-icon” to the taskbar. I unpinned it again and went into the program folder “C:\Program Files\LibreOffice\program” and using each app’s *.exe (swriter/scalc) file, I right-clicked each one and selected “Pin to taskbar” and it then pinned the shortcuts to the taskbar using the “correct” app icon. Now when I open the apps from anywhere the icons don’t change. This is not the solution I was trying to find, but I suppose it’s better than nothing. I hope someone can still help me with my initial query/problem. Thanks

Ahh - you probably have a corrupted Windows icon cache … Check and hope rebuilding your icon cache will help

Hi there, thanks for mentioning this possible solution. Anyway, I tried it and no go, it didn’t help. Just FYI, my PC crashed a day ago. Though I don’t think it was this advice that caused that as I tried your suggestion here about a day before it crashed. I think the crash was related to a SmartDefrag I ran where I enabled moving “most frequently used files to front of drive”. The crash was related to BCD boot corruption. I managed to restore my PC using a full system backup from 24 April, so I’m back up and running now. My icon issue is still present, but like I mentioned I pinned shortcuts to taskbar and it’s my work-around for now till I can figure out what is causing problem.

Hit this problem when my installation upgraded to (x64) this week on a Windows 10.0 Pro Version 2004 Build 19041.572 Desktop.

None of the proposed solutions I found around the web worked, but I did come up with a fix that worked on my PC.

  • Right click the LibreOffice Calc icon in the Start Menu
  • Select More > Open file location
  • In the Explorer window that opens, right click the Calc icon
  • Select Properties
  • Click the Change Icon… button
  • Click the Calc icon picture
  • Click the OK button
  • Click the OK button
  • Click Continue in the Access Denied dialog

Thank you so much for sharing your solution. I had the exact same problem and your solution worked like a charm!

Had the same problem on an updated version (7)
Clearing the cache solved it (icon directory under [user]\AppData\Roaming\LibreOffice\4\cache)

This worked for me - Thank you

For those like me who tried all this suggestions and it didn’t work, this is what i did:

  • I downloaded a libreoffice icon png file from google (search for Libreoffice icon)
  • i converted the file to an .ico file using a free online converter and put this file somewhere on my hard drive
  • Opened a LibreOffice Writer file, right click on the task back icon of LibreOffice Writer (which is still white/blank at the moment) in the little window click right click again Libre Office Writer and click Properties.
  • Click the “Change Icon” Button and then Click Browse and go select the .icon file you downloaded and click apply or ok.
  • Now this is where it’s a little inconsistent, at this point you might have to restart windows, and also unpin/pin the Libre Office Writer a few times in the taskbar, but with a combinations of thoses it should (hopefully/maybe) work
  • Good luck