Libreoffice touchpad scrolling the pdf reader app

So, I’m having this issue since older versions of LibreOffice (I’m using the newest) and my PDF reader (actually have two different pdf readers. It happens to both). When I have both a pdf and a LibreOffice (calc, draw, etc.) app open, if I try to scroll through some document in LibreOffice, it scrolls my pdf. This happens either with the apps side by side or with the pdf reader minimized. As I have tried with more than one pdf reader, I think the problem is with LibreOffice, and it’s not the first time mousepad scrolling has issues in LibreOffice. Could be a windows problem, although I haven’t notice this happening with any other app besides LibreOffice and my pdf readers.

Why would the mousepad scroll a window that doesn’t have focus? It could be the mousepad driver or maybe you have some extra utility software installed that manages windows.

Try following the steps from this Microsoft answers site Scrolling on Windows 10

You could change a mouse setting. Click Start menu > Settings > Devices > Mouse and turn off Scroll inactive windows when I hover over them.

Thanks for the reply. None worked unfortunately. I’d be surprised if it worked, as I have done some of those things before. I think it may be some mismatch between libreoffice and the touchpad’s “gestures” drive (seems to have a specific), the same that makes the two fingers scrolling and three fingers switching windows work as well as others “shortcuts”, which has had many problems before. Don’t know why an unfocused window is being scrolled, makes no sense to me neither

Does it happen with an external mouse? If it doesn’t then it is the mousepad driver.

What are the pdf applications affected?

No, it doesn’t. Just with the notebook’s touchpad. The apps are Adobe Acrobat Reader and Foxit PDF Reader. I’d not be surprise if it was a driver problem, but I’d expect this problem to occur with more apps, it seems too specific. Yesterday, Windows update installed the drive after I had deleted every driver related to mouse and keyboard, so it’s supposedly updated at least. Gonna check again on the manufacturer website