LibreOffice UI Dialogs slow to open

Using LibreOffice I’m finding that whilst LibreOffice now starts up quicker than ever before, with every successive release the formatting dialogs seem to get slower to load each time. By dialogs, I’m referring to, for example in Writer,
Format → Character
Format → Paragraph
Tools → Options
Styles → Modify

in Calc the Cell Format dialog is also very slow and others are slow. And even after the dialog has opened (takes 10-30 seconds) when I click a new tab there’s another delay before the contents of the other tab within the dialog appears.

The computer is now quite old but it has plenty of memory available and no other program runs this slowly.

I also experienced dreadfully sluggish ui dialogs with on windows xp. Solved it by letting LO rebuild C:\documents and settings\username\Application Data\LibreOffice.

Rename that LibreOffice user directory to retain a backup copy of your settings located in the directories under C:\documents and settings\username\Application Data\LibreOffice\3\user. You might need to launch LO twice for it to rebuild those directories and start normally. From the backup, I copied back autocorr, autotext, wordbook, and my Module1.xba located in basic\Standard. Surprisingly, I could also copy back and overwrite all of config. The only real change I made was to freshly install the latest versions of extensions I use (and therefore didn’t copy back extensions and uno_packages).

Now, indeed, LO is faster than ever before.
HTH, Peter

That’s great - worked a charm. In fact I cheated based on your comments about what you didn’t copy back - I just renamed the extensions and uno_packages folders, leaving everything else in place. It even automatically reinstalled all the extensions I had! Now how do I ‘accept’ this answer?

Impressive. In my Win7-4, Core2 Q9650 3Gz, 4GB Ram, when I selected a 10x10 cells rectangle and right-clicked “Format cells” it took 20 f*ing seconds (sometimes more!) to open the dialog!!! After deleting \AppData\Roaming\LibreOffice\ not it opens in less than 1 second. Is this a known issue?