Libreoffice upgraded, Writer no longer recongizes many system fonts

UPDATE: Now filed as a bug: fdo#115723 and see work-around posted as answer, below.

This morning I got the LibreOffice upgrade from 5.4.3 to 5.4.4 (Version:; Build ID: 1:5.4.4-0ubuntu5, to be precise).

It seems to have “removed” a number of fonts I had locally installed on my (standard Ubuntu) system. This include:

  • my SIL fonts, including Andika New Basic, Charis SIL, and Gentium Plus
  • all the ClearType (Cambria, Calibri, etc.) fonts
  • PT family
  • SBL Greek and SBL Hebrew
  • … and more.

Just to make it really weird, some persist: e.g. IA Writer Duospace, Merriweather [serif and sans], Venturis ADF, one or two others. These are all installed in the same way and from the same location as those listed above as missing in LibO.

Now, this behaviour seems to have been noticed on the LibreOffice bug tracker, and it’s pretty bad behaviour, I reckon. (IF that’s what I’m experiencing.)

These fonts are still in ~/.local/share/fonts, so I simply ran sudo fc-cache -f -v expecting them all to re-appear in my LibO install.

But they haven’t shown up. I re-ran the fc-cache command, logged-out, logged-in, … still not showing up.

How can this be? I’d prefer not to have to install AbiWord (or something) to check other apps, to see if other applications can access these fonts. (Actually, I have a Markdown editor that I have set to use Andika New Basic, and it seems to find it just fine.)

I’m not even sure I’m understanding where the problem lies. But I would VERY much like LibO Writer to use the fonts I have installed on my system, many of which are my day-to-day workhorse fonts. I confess to being somewhat grumpy.

This question has also been asked on AskUbuntu.

Thank you for filing the report! I hope that your workaround won’t be required for long (but I don’t hold my breath ;-))

@Mike-Kaganski - Thanks for investigating the bug report. Looks like either it’s (a) something quirky on my system; or (b) already fixed in I’ll await the next Ubuntu update (hopefully 6.0+ will come through soon – very impressed that Collabora Vanilla LibO is already there on my wee MacBook!). At least the workaround is painless and effective. :slight_smile:

After filing a bug report with LibreOffice some things came clear: describing the problem really does help!

After much head-scratching, it dawned on me that the problem ONLY affects locally-installed (per-user) TTF fonts, but it does not affect locally installed OTF fonts, nor does it affect TTF fonts installed system-wide.

The work-around, then, is to move any ~/.local/share/fonts/*.TTF files to /usr/share/fonts/truetype/, then run sudo fc-cache -f -v.

At least this means that the fonts are available to LibO Writer (and Calc, etc.), although it still seems like a bug to me.

Unfortunately this may not be as simple as a bug in LibreOffice.

I have a system with LO 6.0.1 and tried this, and it had no problems recognizing fonts installed in my local user. At the time I assumed that meant whatever the issue in your version was was likely fixed.

Sadly I just came across one of my systems (Archlinux) that hasn’t been updated for a while and has LO I figured I’d have a look. Finding a TTF font file that only existed in my user’s font path not the system, I fired up LO and low and behold, that font was in the menu and worked just fine.

I’m going to go out on a limb and suggest that something happened during the build and packaging on Ubuntu. Perhaps something with fontconfig was misconfigured on the build system. I’m going to guess that if you built the same version of the package yourself this might go away. Off the top of my head I’m not sure how to do that on Ubuntu these days, sorry.

Alternatively any other build of the .deb package whether a newer or slightly older version might work. Also if we can figure out how to poke the Ubuntu packager to get it to bump the build number and recompile LO that might even do the trick. Is 6.0.x not available in a Ubuntu package somewhere?

I’m not sure I understand your bottom line correctly; but for the record - the 6.0.1 version from PPA (i.e., the source of all official packages on Ubuntu) works for me.

Thanks for taking time to look into this, @Caleb - appreciate your thoughtful attention!

@MikeKaganski The bottom line of this suggestion is that this isn’t directly a LO bug, but was an issue specific to LO+Ubuntu packaging. Without access to the failing system to test I’d say the best solution is to upgrade to 6.x and move on.

I can confirm that LibreOffice is not picking up the fonts in ~/.local/share/fonts/ in Ubuntu at least.