LibreOffice (v5), how to add JRE to product?

I a new user to LibreOffice, got v5.1.1.3 load. Trying to run BASE and pop-up noted I required JRE. Down loaded and installed JRE. Restarted LibreOffice, start BASED same error. Reboot my MAC OSX (v10.11.13) still no joy. Went to LibreOffice advance, JRE not listed in Java Options environment. Attempted to “Add” but no joy, could not (greyed out) select the JRE.dmg file (assuming that is what I had to do, a long shot), so am at loss.

Note: am not a techie (well I once was but that was in the mainframe days, just after stone and chisels era)

So, any help / direction would be most welcomed.


In Java Options (in LO Advanced) box at top of page should be checked - Use a Java runtime environment. Add button is greyed out if this is not checked.

JDK rather than JRE is now required. Refer answer here.

Hi Oweng, thanks loading JDK worked! Yahoo!
You’ve made my Easter weekend, now I can dig into learning BASE.
Happy Easter,

Thanks oweng, I didn’t catch that. Stephan, that kind of explains what you were seeing. If when selecting Add all items were greyed out, there were no folders there - only files. Mine is pointing at /usr/lib/jvm/java-7-openjdk-amd64/jre folder on a Linux system.

after I installed JDK, it appeared in LO Advance, just had to enable it and bang all was good.
Cheers mate,