LibreOffice, version crashes frequently

LibreOffice, version crashes frequently.
This happens frequently: when I scroll through the document with the mouse wheel or the scroll bar.
What should I do?

1 Like

Isn’t it this bug? 153059 – CRASH: Clicking on the header/footer button after scrolling

If it isn’t the specific bug mentioned above, then have you tried disabling Skia in Tools > Options > LibreOffice > View? Cheers, Al

[Edit] Maybe you meant version because version has only just been released. The bug 153059 does not affect LibreOffice because it is a recent regression affecting only LO 7.4. Even fixed for LO 7.5


I get this exact crash many many times.
It occurs in 7.4 and 7.5 just from scrolling in Calc.
Open a calc document with a fair amount of data and just scroll around. Keep scrolling clicking and dragging the scroll bar. Release mouse button. Do it again. After a few times it will hang then crash.

@SleepySpider Please try my suggestion above

I disabled skia and now it works, No crashes
Thank you EarnestAl

Thank you for this idea – so far, it’s working.

I disabled skia but it was insanely slow. Almost unusable. So I enabled Force Software Rendering enabled but left skia also enabled, and that seemed to be good. It was fast and no hangs/crashes yet. Thanks.

Also I’m using so it must not be fixed entirely.

Try updating your graphics card driver.

1 Like

I Updated the nvidia drive to latest version, but with skia rendering enabled it crashes in the same way too :frowning:

I suppose exists a bug in this version of Libreoffice.

If your graphics card is unable to properly handle Skia then tick the box Force Skia software rendering

Hello EnrnestAI,
thanks for you reply.

Note that before this version I was using 7.4.6 and with skia enabled (with hardware acceleration) and the problem had never occurred

Thank you. It was happening only to one document. Did as yousuggested and then reenabled Skia and it wirked. Then as @SleepySpider said, I reenabled Force Software Rendering enabled. Can’t do that without Skia being enabled. Anyhow, between the two of you you got me working again. Thanks again.