LibreOffice will no longer save a .odt file to .docx.

LibreOffice will no longer save a .odt file to .docx. I used to be able to do this on my iMac but now going through the motions I used to use successfully just produces a TextEdit file. (I can still do this ok on our PC laptop.) I am using

Should I uninstall LibreOffice and download and install a new copy?

Sorry to be diffident, but can someone please direct me to step-by-step guidance on how to do this on an iMac?

Please describe how you create your .docx file. If you do a File -> Save As and select Filter Word 2007–365 (.docx) it should not happen a .txt file being created. Or does your question mean: If I double click in Finder on a .docx File, then it opens in application TextEdit. If that’s the case, then your file extension association of .docx files has been changed (May be by installation/update of TextEdit application).

Don’t uninstall LibreOffice now, let’s clarify the real issue first.

You didn’t specify which specific “motions” you used to use successfully that fail now; and what specifically you mean by producing “a TextEdit file” (does the resulting file have no .docx extension? don’t you just have an OS association of .docx files to TextEdit?).

Cross-posted with @anon73440385 :slight_smile:

Replying to Opaque and Mike Kaganski
The way I have done the conversion successfully in the past (and still do on the PC) is by doing Save As procedure and then changing the file extension – I can’t remember precisely which one because there are several forms of words with .docx or .doc in brackets after them. I tried them all last night, I think. Every time I think it looked at the time as if I’d done what I wanted, but then invariably in the finder they were listed as TextEdit.

does the resulting file have no .docx extension?

I have just done a test conversion noting exactly what I’m doing.
I click Save As from the File menu of the .odt document.
In the file type areaI specified this:
Microsoft Word 2007–2013 XML (.docx)

In the new document I went to File > Properties > Type.
There, where most of my ordinary word-processed files have hitherto said “MS Word document”
or “OpenDocument Text”, it says “Type”.

I’ve just looked in the Finder and there, under Kind, it says "TextE

What is the extension of your file(s) in Finder - .txt or .docx / doc?.(It is of no interest if Finder tells any association (in column Kind) to an application (TextEdit), because this may be the misleading information, that it is a text file while in fact it still is a .docx file).

Just don’t try to open your file by clicking on the file name on Finder but use right click and use Open With and select LibreOffice (may be you need to use Other any select LibreOffice and tick Always Open With option)

In Finder the filename of the test conversion I described above does not show an extension (which is why I looked at the Kind column).
When I R-clicked and chose Open With I was not offered Word or LibreOffice, only TextEdit, TextEdit (default), App Store and Other. When I clicked Other, LibreOffice was greyed out.
Incidentally, the reason I want to convert .odt files to .docx format is that I want to be able to send attachments to people who use Word rather than LibreOffice, which I used to be able to do. I am using LibreOffice because Ms Word for Mac 2011 is hardly functional at all on my iMac now that I m running Mohave. (I read that Word for Mac 2011 is 32 bit and Mohave is 64 bit. I don’t understand this subject but can imagine the sort of incompatibility it could be.)

Could you prepare and attach here a sample?

Are you sure that the problem just is option Automatic file name extension not ticked when using Save As? If your file has no extension after the export - just rename a file to have the extension and check once more. Please check your procedure according to the following screenshot: