Libreoffice Write does not allow double capital after a period.

I cannot type the following: “www.WHynot” It is automatically changed to “www.Whynot”. I can type : “www.WHYnot” or all caps “www.WHYNOT” but two capitals following a period will not work. And, yes I have unchecked my Autocorrect. This bug would prevent using Write for writing anykind of code-like text.

All you need to do is uncheck COrrect TWo INitial CApitals in Tools - Autocorrect - Autocorrect Options, Options tab.

Sorry, it does not work. See attached and also note that a number following two CAPS will preserve the caps but a lower case letter will change the cap to lower case.autocorrect3.pngdrawing.png

I finally solved the problem but I do not know why it works: Rather than reinstalling Libreoffice, I removed all language packages (dictionary, help, etc.) that were automatically installed in Libreoffice, except for the various English flavors. Rebooted the computer, unchecked all the autocorrect options in Libreoffice Writer and now everything works as it supposed to. Since there were more than half a dozen languages installed, I have no idea which caused the problem, or even why deleting them worked.

What version of LibreOffice?
What operating system?

I just tested this in LibreOffice x64 on Windows 7 x64 … and it worked as expected.
When I disabled it I could type your examples text with no AutoCorrect changes affecting it.


here is the version: Version:
Build ID: 1:6.0.3-0ubuntu1
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3;
Locale: en-US (en_US.UTF-8); Calc: group
and the OS is Linux Mint 19.0 16bit

sorry, OS Linux Mint 19.0, 64bit