LibreOffice Writer 4.2.8 How do I change the default image anchor to character? Has this bug been fixed?

Please do not mark as duplicate since the last question of this sort as asked (to my knowldege) 3 years ago.
The original question was “How do I change the default image anchoring to “as character”?” The question was erroneously marked as answered, but the answer given was simple links to bug reports. I assume that by now the bug has been fixed, but I still cannot find the way to do this. I guess the hidden question here is “Is LibreOffice still in development?” I say this because the answer 3 years ago include a comment “A popular topic since OOo 1.1 ;)”


If you are using LibreOffice dialogs (menu Tools Options LibreOffice General Open/Save Dialogs) you can choose the style to apply to the image when it is inserted. So just create a Frame Style with anchor to character and use it. This video (in french but manipulations are enough to understand) shows step by step.

Note: on windows you can choose the style but it is not applied if you use “system” dialogs.

There are so many innovations for 3 years that I think this part of your question really does not expect an answer :slight_smile:


Actually I am trying to change the default behavior of the program. Otherwise I would just right click the image and apply the “anchor” → “as Character” without the need for creating new styles and opening the styles and formatting box every time I try to insert a picture. You have to understand that I create many documents with maybe 50 images per document. It gets pretty tedious updating every image. But thanks for your response.

Presetting the anchorage - as of version 7.1

The anchoring for inserting images can be preset from LibreOffice version 7.1.

Select Tools>Options>LibreOffice Writer>Formatting Aids from the menu.

For Image/Anchor you can select: To Pragraph, To Character or As Character.

1 Like