LibreOffice Writer documents printed on Epson default to Letter 216x279

I would like my LibreOffice Writer documents to print in A4, the standard paper size in the UK. However when printing on the Epson XP-6000, the paper size defaults to 216x279.

Epson Support previously found a fix, but the problem has reappeared around 9 months after it was fixed. The problem occurs it seems only in LibreOffice Writer, at least it does not occur in my old Word Doc program.

ISO A4 actually is 210 mm Ă— 297 mm based on general definitions.

  1. May it be that your “216” is a typo?
  2. Despite the fact that ISO paper sizes of the A-series are global standard in correspondence for decades now (and only negated by US authorities and habits), a recent printer may not know how to handle and report them. NI lacking.
  3. Did you check Epson XP-6000 | XP Series | All-In-Ones | Printers | Support | Epson US for a probably recommendable driver update?
1 Like

Not likely, as the given size is US-letter.

The question is: Where is the origin?
Either in printer-settings, local settings or within LibreOffice maybe introduced via templates.

Then the next question is, why changes are not kept. (I remember complaints about Windows to “forget” custom paper sizes. So this may related.)

As printer-driver, Windows and LO interact, it is a bit complicated.

I have the latest driver

There is an option to load printer details with the document. Deselect this, or save after switching to A4.

Yes true, but at next printing the system reverts to 216x279, not only here, but recently (I have found) at every choice-point. Since I never use 216x279 but only A4, this is extremely frustrating.

Can you repeat the setting made previously? An update to the driver or to the operating system might have reset it to manufacturer’s default.
What operating system?
What is the location set in the operating system?
What are the printer defaults set in the operating system?
In LibreOffice, what location is set in Tools - Options - Language Settings - Languages? If it is set to English (USA) and you change this to English (UK) and OK, you might have to close out of LibreOffice completely and open it again before all settings are changed.

1 Like

Not really sure what you mean. I can reset everything to A4 yes, but the system resets itself at next use.
Windows 10 is the operating system
English UK in both operating system and LibreOffice - of course!
BUT When I look in File | Print I see Paper Size: A4 210 mm x 297 mm But I also see the dimensions of the image showing me what is about to be printed as 216 mm (letter) and 279 mm. In other words the Print display screen is contradicting itself.
And in General | Properties | Paper Quality | Advanced, it displays “Letter”. I can set it to A4, and the image will change to A4, but General | Properties | Paper Quality | Advanced will always reset itself to Letter.

Of course, you know this but have not told anyone so I must ask.
Now for the next obvious check:

  • Is your Epson XP-6000 printer set as the default printer? Click Start menu > Windows system > Control Panel > Devices and Printers in the dialogue , is there a green tick against Epson XP-6000? If not then LibreOffice might be picking up the defaults from the printer that is set as default. You can change any printer to default by right-clicking on it and and selecting Set as default printer

  • In that dialogue, right-click on your Epson XP-6000 printer and select Printing Preferences. In the new dialogue, in the tab Main set Document size to A4 (and any other default preferences you want) and OK out.

Cheers, Al

Having dipped into the manual for Epson XP-6000, I have to ask if you have read page 69 and set the paper size in the printer? Or does the printer say that Letter is loaded?

Selecting the Paper Settings for Each Source - Control Panel
You can change the default paper size and paper type for each source using the control panel on the

  1. Press the home button, if necessary.
  2. Select Settings.
  3. Select Printer Settings.
  4. Select Paper Source Setting.
    You see this screen:
    Note: To turn off the automatic display of the paper settings selection screen after you load paper in
    the cassettes, set the Paper Configuration setting to Off. If you do this, you will not be able to use
  5. Select Paper Setup.
  6. Select the paper source you want to change.
  7. Select Paper Size.
  8. Select the paper size you loaded.
  9. Select Paper Type.
  10. Select the paper type you loaded.
  11. Press the back button to select another paper source to change, or press the home button to

This business with the Green Tick was something I didn’t have/ Click Start menu > Windows system > Control Panel > Devices and Printers in the dialogue , is there a green tick against Epson XP-6000? If not then LibreOffice might be picking up the defaults from the printer that is set as default. You can change any printer to default by right-clicking on it and and selecting Set as default printer

However so far it doesn’t seem to have fixed the problem.
All other settings are as you have suggested.

I think you should follow up on @Lupp 's advice and update your printer driver and firmware if not already done. There was a Windows update that caused problems with many printers so manufacturers had to release updates to solve the problem.
BTW. You might need to restart LO to see effects of changes in Windows settings, or Restart Windows (not Power Off which defaults to hibernate) which fixes a lot of weirdness, especially after Update Tuesdays.

Printer driver is already up to date.

Curiously enough, when around 9 months ago I reported the problem to Epson, the online help fixed it. However for reasons unknown the problem has reappeared.

I have version (x64) on two of my 3 PCs, and on the third. It makes no difference.

Epson’s support seems to be pushing me to blaming LibreOffice:

"Thank you for contacting Epson technical support.

Regarding our recent query about the default document size being “letter” here is what our Level 2 tech team responded:
-Drivers sometimes do revert back to previous settings this usually has to do with the software they are printing from.
-They can create presets in the driver but they would probably need to select them either way.
-Try to print from various softwares to check if it reverts back on all of them."

To which my answer was, no, this problem seems LibreOffice-specific.

Why have you entered a comment as an answer?

EDIT @Hrbrgr: twice!

Thanks @EarnestAl

A few comments on your “answer”

I think Epson are being disingenuous here. Drivers usually revert to default after a driver update (latest 2021-04-30), or a major operating system update (20H2 ? around June/July 2021). The printer LCD panel paper settings are likely to reset to default after a firmware update (latest 2021-07-21, possibly to correct for 20H2).

You quote Word as a single example of the driver being set up correctly. Word has a default setting in File > Options > Advanced > Print of Scale content for A4 or 8.5" x 11" paper sizes. So it does not confirm the paper size is set correctly in the printer or the operating system. It also makes margins look a bit odd in those printouts it “fixes”.

I listed some operating system settings and the printer LCD panel paper setting that needed to be checked individually; you have assured me that you have set them accurately. In that case in Tools > Options > Load/Save > General set Load printer settings with the document
For existing documents, in Tools > Options > LibreOffice > General > Document status you could set Printing sets “Document modified” status to remind you to save after printing so next time the file is printed the A4 setting is already done.

1 Like