LibreOffice writer extremely unstable with large files

Every time I make documents in LibreOffice writer that exeeds about 15-20 mb, largely due to pictures in the document, LibreOffice becomes unstable and stops completely. After waiting a few minutes it works again, but 2 minutes and a few (textual) adjustments later it starts all over again. It often also happends when saving the file.

EDIT: it is very often triggered by scrolling through the document with my mouse wheel.

Does anyone experiences the same problem and, moreover, is there a solutions for this problem?

I work with these large files often (up to 80 mb) and it happens every time, also in 3.x versions of LibreOffice. It makes working simply impossible…

I use LibreOffice on a windows 7 computer.

Thanx in advance!

Unfortunately, the bug of LibreOffice Writer going ‘non-responsive’ is NOT limited to very large files with image objects.

I have an odt file that is only 1MB in size, but it has lots of font changes (embedded symbols - like those in Webdings and Wingdings fonts) and it too suffers going non-responsive for minutes at a time after a file save (Ctrl-S). And I run it on Win7 with i5 CPU with 4GB RAM and 500GB SSD, so never waiting on any other process, like a physical drive.

This file has been maintained in MS Office, then Open Office and now Libre Office for about 15 years. And only in the last four months has it started to not display sections of hidden text (even when display-hidden is turned ON), and the saved filesize now keeps growing, from 1.2MB to 2MB a few months back and now 4.5MB, with virtually nil increase in content. Now, I have just done a Select All (Ctrl-A) and then deselected Hidden Text (to return all hidden text to visible) and saved, and filesize returned from 4.9MB to 1.2MB. So, there is definitely a BUG in LibreOffice handling large and/or complex files.
Graeme Harrison (35 years IT experience)

There was an earlier related unsolved thread in 2013: ‘Libre writer can’t handle big file’. Most of the discussion was about images. Solutions proposed were to use Scribus (which I use a lot), and to split documents using the Master document facility.

Like Graeme Harrison, I have to work with a document that began with Word (on a Mac in my case). It has > 1000 pages but no images and the file is only 5.4Mb. As described by other contributors, I can’t get it to work on LO 4.1 writer, on a 64-bit Windows 8.1 pro installation.

The reason for using LO is to make an ebook (ePUB) using the eLAIX extension, a common requirement nowadays. That rules out Scribus, and source documents for ebooks must not be split. Other ebook software has to be paid for, so I hope this difficulty with LO will be solved before long.

Update: I had the occasion to try the same file (it’s in Dropbox) on various systems, which I won’t describe as nobody is going to do detailed diagnostics. It worked with no problems on OO on Vista (Dell, 2007) and on LO 4.2 on the same machine running Ubuntu 13.10. No problems on another Dell (2013) running LO 4.1 onWindows 8.1 Pro. I then went back to the original machine, a Toshiba Satellite (2012), LO 4.1 on Windows 8.1 Pro updated from W7… and was unable to reproduce the problem, even with plenty of other programs running. It would be hard to take this further without going into the details of automatic Windows updates and so on.

It seems that this difficulty affects a fairly small but unknown percentage of users, and that it’s proving difficult to diagnose. I spent some time on it because I recently encountered a statistically strikingly similar unsolved case that dates back several years, where all web browsers crash with Ubuntu-derived Linux distros, making the installation unusable. There are lots of posts on the Ubuntu forum.

These situations are worth discussing, because although they are rare, they may contribute disproportionately to a common impression that free open-source resources are less reliable than the expensive commercial offerings. My Linux problem happened on an old XP machine & I just gave it to someone who was willing to stay with that. But I can’t replace my Toshiba, and I can’t afford MS Office (which doesn’t have all those useful extensions).

Sometimes, in paranoid moments (I have a little experience of industrial “dirty tricks”), bearing in mind the financial stakes, I wonder whether these occurrences really are genuinely accidental, though I don’t know if such a comment is appropriate here.

Please try looking with the Navigatro [F5] if there are strange or duplicated objects in the file.

I was convinced that it was a large file problem, but I think it isn’t. LibreOffice Linux 12.04 LTS
This file is like 30 MB. I had already been hanging the memory required for LibreOffice.

Recently I copied an HTML file from a chat session into a new file and it hung.

Generally, I’ve been copying stuff from HTML pages (Firefox 66) into a large document, but I didn’t realize the connection. The hang would happen immediately.

When I used "Paste Special Unformatted text, the problem seemed to go away.

To bad, I didn’t think about View source and creating an html document from that.

Have you adjust the memory settings? Menu/Tools/Options/LibreOffice/Memory, adapt according your needs, 256 MB of graphics cache for LibreOffice is the maximum.

Thanks! Didn’t know that. I adjusted the settings and it does help…, but the problem is not gone completely. It still stops in the large files, but the time it stops is tremendously reduced from up to 5 minutes to 5-10(max.30) seconds.

So thank you very much for your advice. Problem is not over yet, but in comparison to what is was, it’s (almost) acceptable!

Best wishes,