libreoffice writer image not saved

When I copy an image (e.g. .jpg) into a document (either .docx or .odt) it appears correctly. However if I save and reopen the document, the image disappears. (Other changes e.g. changes to text are saved.)

I’ve looked at Tools>Options>LIbreOffice Writer>View>Display>Images and Objects; the appropriate boxes are checked.

What am I missing?

I’m running LibreOffice 6.4 on Windows 10 Version 2004 (build 19041.388)

Have you tried View > Images and Charts? Or has the image entirely disappeared without any rectangle?

In the sidebar, click on the compass icon (Navigator), are there the correct number of images listed? If there are images listed but you can’t see any, what happens if you double-click one of the list items?

When I paste the image into the document before saving, and I do View > Images and Charts, this item is highlighted. If I unhighlight Images and Charts, the image is replaced by a box. Rehighlighting Images and Charts causes the image to appear again. If, before saving, I click on the Navigator icon, 1 image is specified.

After saving and reopening, the image is gone. View > Images and Charts is still highlighted. The Navigator icon shows no images. (Changes I made to text in the document before saving are reflected in the saved document upon reopening.)

That’s odd, I am running LO on Windows 10 Version 2004 (build 19041.388) and no issues like that whatsoever. Even when saving the file in different formats, the pictures were OK. I was going to try but the site seems to be down at the moment.

Try Tools | Options, in the window that opens got to LibreOffice | View and untick “Use OpenGL for all rendering” and see if that solves the issue.

If OpenGL is already unticked then try opening LO in safe mode Help | Restart in Safe Mode and see if the same thing happens. If the problem has gone in Safe Mode then Archive your user profile and then reset to factory settings. You will lose user dictionaries, user auto-correct entries but you might be able to copy back just those individual items from the zipped archive

OpenGL was not ticked. I restarted in Safe Mode and went to factory settings. Then when I tried to duplicate the problem, I got a message “This document may contain formatting or content that cannot be saved in the currently selected file format “Text””. I picked odt mode and the image was saved successfully. (Apparently I mode the wrong choice in this warning window sometime in the past.)


OK. Here’s a tip: regardless of the office suite you use, always save in that suite’s native format, it’s the default (unless you have changed the default). If you need to share with others make a copy of your document in the foreign format at the time of sharing. If you do this frequently there is a LibreOffice extension that allows you to save a copy in another format each time you save in the native format.