LibreOffice Writer: Indenting doesn't work anymore


I have an .odt document with 83 pages. I would like to indent the first line in a paragraph using TAB, but for some reason this doesn’t work anymore. What can I do?



Show the file.

Does this happen in only one paragraph? Then, what are its properties?

The “normal” way to indent the first line of a paragraph is through attribute First line indent of the paragraph style. If consistently styled your document (which is mandatory for such a long text), you only need to customise Text Body paragraph style. You didn’t use Default Style everywhere, did you?

Your case is hopeless. You could as well have used an ASCII text editor for the same result.

I add to @Zizi64’s remarks: don’t use frames to add borders to paragraphs. You break text flow (frame content is outside the main text flow which can cause issues when you need strictly continuous order, like building automatic TOC. The frame content may not appear where you expect it.)

Down load the Writer Guide, read it and style your document as it should.

You didn’t use Default Style everywhere, did you?

I’m afraid I did. :frowning:


1 Like

Do not answer your own question unless it is a real answer.

Ohhh NO! The Office suites are not typewriters… You need use (for the more efficient working):

  • the Paragraph Styles, to formatting the paragraphs - instead of the manual (direct) formatting method)
  • the First line Indent feature inside a Paragraph Style - instead of the spaces, TABs at the first line of the paragraph ,
  • the Page Styles - for the Cover Page, for the TOC (if it is exists in your documenet)
  • the Chapter Numbering feature - if you want to create a TOC (Table of Contents) automatically
  • the enforced page breaks (Ctrl-Enter, or the relevant Menu item) - instead of lots of Enter (lots of empty parasgraphs)
  • …and many more features which the office suites was developed for…

You MUST reformat your whole document…

I’ve bumped in to what seems to be a similar problem with a long file that suddenly won’t tab the way it used to from the start of a line.
Can you explain a little further why Writer is unable to handle this? The character count increases, but no tab registers – why is \t not handled consistently like any other char?
Many thanks!

It is able. You should be able to press Tab at the start of a paragraph, and get some (specified, but varying depending on some details) result. Specifically, Tab would insert a tab character in normal paragraphs; but it would increase list level in paragraphs belonging to lists; and it would go to next cell in tables. (And there is a key combination - Ctrl+Tab - to insert tab character in that case.) Also a different thing is when people misuse line breaks for paragraphs …

But note that people answering questions here have strong reasons to not encourage typewriter-style use of what is not designed to be a typewriter. Myself, e.g., has too much sad experience with awful results of such “use” of the tool, and would hate to see some such “document” received from bank, or from another organization, from someone pretending to have word processor use skills, but actually using any word processor that way - because I would spend too much time rectifying that … work of art.

Thanks so much for your rapid reply – I appreciate your passion! :smiley:

I may have phrased my question poorly, but by inconsistent I meant that in seemingly the same contexts I am experiencing different behavior and I can’t identify any style or format setting that I’ve accidentally changed.

That is to say, the tab indent worked as expected in my document until one day the existing tabs disappeared and new ones don’t render. They still exist – inserting and deleting tabs alters the char count – but they are no longer visible. The same text copied to a new document displays them fine.

I love Writer because I find it quite intuitive and I’ve learnt a lot of useful keyboard shortcuts that improve my productivity and help structure my work – I do use systematic styling for a lot of things. But for parts of this particular document (course notes, for personal consumption!), I just want to be able to indent something add hoc.

From the original post and the replies, I am unsure whether I am having trouble because after a certain length odt files just get corrupted and / or render badly (as a result of my using bad / inefficient formatting?) or whether something else is going on.

Do you think this is my problem?

a different thing is when people misuse line breaks for paragraphs …

Perhaps my issue warrants opening its own ticket, but I felt it matched this one quite closely, so I really appreciate you coming back to it!

Possibly it needs a ticket - but in fact, a sample document could possibly enable others to see your issue; it might be some compatibility option, or something else. You could try to clean up your document to remove sensitive info, making sure that you do not have tracked changes, and upload here.

1 Like

Check the paragraph tabs positions.

1 Like

You should have started a new topic about this issue.

1 Like

In Tools > AutoCorrect > AutoCorrect Options > Options do you have Apply styles ticked? If you do then LO will convert your tab to change the paragraph style to First Line Indent as soon as you press Enter at the end of that paragraph. The default indent for First Line Indent paragraph style is 5mm but if that style has been modified then who knows?

1 Like

Thanks everyone, changing the tab position helped! I hadn’t tried it before because it doesn’t seem to be set differently on new documents. But it did the job!
Appreciate everyone’s help :pray:

First mark those paragraph that are space-tab-dented:

  • Choose menu Edit - Find & Replace… (the same that Ctrl+H);
  • In the Find: field type ^[:space:]*|\t*;
  • In the Replace: field type @;
  • Check Regular expressions, and
  • Press Replace All.

It would add the @ character at the beggining of those paragraph. I choosed @ because it is not present in your text.

  • In the Find: field type @, and
  • Press Find All, and Close.
  • Choose menu Format - Paragraph… - Indents & Spacing tab;
  • In the First line: field type 1.25 cm;
  • Press OK, and
  • Delete (the key) to delete all @s.

Tested in LibreOffice (x86); OS: Windows 6.1.

Add Answer is reserved for solutions.

Press edit below your question if you want to add more information; also can comment an answer.

Check the mark (Correct answer mark) to the left of the answer that solves your question.