Libreoffice Writer is no longer saving my cursor and troubleshooting steps aren't working. What should I do?

I am currently using Libreoffice Writer

Libreoffice Writer is no longer saving my last cursor position.

I have gone through the documentation, making sure my name is in the field, making sure that “load user-specific settings with the document” is checked, made sure that “Apply user data” and resetting the properties under file->properties, and making absolutely sure that I’m saving as an ODT and nothing seems to be working.

What else should I do.

Edit to add: I’ve tried using Safe Mode with the first name box filled and it hasn’t solved my problem.

Hello @deananorth, Take a look at the guidelines at LibreOffice user profile - The Document Foundation Wiki to see if it can be caused by corruption in the user profile.

Add Answer is reserved for solutions. Please, click edit below your question if you want to add more information.

Thanks for your advice, but I’ve followed the instructions (saved the document while in safe mode) and it hasn’t solved my problem.

This issue pop-ups in every document? Have you tried to open the document while in safe mode? This document was previously saved as .doc(x)? Share your operating system. Thanks.

It happens to every document.

If the document already had a set cursor position, the cursor position would be reset after saving.

The document I first noticed this with was an ODT document.

The issue occurs while opening and saving the affected documents in safe mode.

I am using Windows 10 20H2, build 19042.844, with Windows Feature Experience Pack 120.2212.551.0

Update: Updated to LIbreoffice
The issue seems to persist.

I created a new local account (Microsoft made this difficult) and saved my document.

I edited and saved it there. Upon opening the document, the cursor is close to where I saved.

Upon opening the document in my main account, the cursor is at the top of the page.

It is of note that I’m usually signed into my Microsoft account.

I tried to reset my user profile by moving the user folder as located in the cheatsheet.
My settings were expectedly reset. I inputted my name in the first name box as mentioned in another article.
I saved the document and reloaded and the cursors position was not saved.

Perhaps it’s a problem with my Windows Profile/Microsoft Account?

That’s what I did when I tried to implement your fixes.
Open document. Make a minor edit. Save. Reload the document.
Also Use data for document properties was already checked.

Are you saving documents in ODF format?

I save documents in ODF by default.

My lab: Windows 10 updated til this week. LibreOffice
Profile ok, user data ok, user data apply to documents ok, ODT documents from the scratch OK. Last position works fine.
Isolated case for 2 documents (i think ODT original) which have some kind of issue when opening. It does not recover LAST POSITION, but if you press SHIFT + F5 you will recover LAST POSITION. This means last position is saved in any case.
Copy all and paste without any format in a clean new ODT document. Apparently it works, document opens in last page which I edited, but no cursor is shown. I begin to format paragraphs, heders (H1, H2) and save. Issue is again!
Copy all and paste in Notepad. Save as TXT and close document. Open Notepad again and select all, open LO and create new fresh document, paste txt content and save as ODT. Try to modify something and issue again!
Conclusion: Some strange or corrupt character that I have not found yet.

Yeah. That sounds like a bug in the formatting/heading system or something. I’ve tried saving all over my affected documents and it doesn’t seem to save the cursor position past a certain point.

Shift+F5 is the only thing that works for me - using on Archlinux. I’ve done the requite chase your tail exercises - nothing works. Shift+F5 is my new friend. I write books, so when editing really need to pickup where I left off - but it doesn’t break my fingers to type Shift+F5… it’s just minimally annoying…

I’ve updated LibreOffice (x64) catalan. It seems that this issue is solved. At first, I thought it wasn’t solved. For me, document load, last page and last cursor position saved work fine!

I have LibreOffice catalan on Windows. This feature was working fine for me, until yesterday when I upgraded to I have checked everything that has been said: Profile, User data, apply data to documents …
Of course, all documents are ODT from the scratch. Only SHIFT + F5 works to go to last saved position. But, it is with the new documents that DOES NOT WORK FOR ME, the old ones (a year or so), it works.
–>One more thing, with a simple blank test ODT document, seems to work, but after a while, when you write some content, begins to fail.
It seems that last position is really saved, but when Writer opens doc, does not know where it is. You have to press SHIFT F5!

That seems to be a new question or comment. On this board, answers are reserved for solutions for the original question, not for discussion. Please don’t ask your question in an existing topic.

Sorry! I only want to share my expirience with the same problem. I wanted to say that: “It seems that last position is really saved, but when Writer opens doc, does not know where it is. You have to press SHIFT F5!” and for me, it’true. I’ve just testing with fresh documents and I have news about it. How can I post them? It’s a kind of workaround. Thanks!

I’m sure that while it is a workaround that works for you, it doesn’t make the problem go away. Have you reset your user profile?

Yes, I reset profile.