LibreOffice Writer keeps scrolling to the top with Gnome overview

Whenever I’m in Gnome’s overview and I click on the Writer window, it scrolls to the top of the document. This is super annoying, especially since the document I’m working on has tons of graphics and runs at about 3fps. It’s a major pain to keep scrolling back down to where I was working every time I bring focus back to the window. Is there a work around or fix for this?

LibreOffice Writer flathub | Debian 10 Gnome 3.30.2


are you sure that this is related to GNOME in any way?

To have LibreOffice remember the last position you worked on, you need to fill data into Tools -> Options -> LibreOffice -> User Data -> Field: First/last name/initials (initials only is not sufficient).

I set my first and last name in the options, restarted Writer, but it still has the same issue.

Ok - just tested with and there seems to be a new bug. See tdf#140147 - position of cursor not saved

So this looks like a bug(mentioned above). I got rid of the flathub LibreOffice and installed the Debian repo version, which works perfectly. I must say, Debian’s packages are quite old, the interface looks like it’s from the 90s.

the interface looks like it’s from the 90s.

…then you missed to install GTK3 support using sudo apt install libreoffice-gtk3

Thank you, I ended up needing libreoffice-gnome.