Lightproof not installed with

Lightproof not installed with It will not install as extension with some long wrror message that only a computer expert could understand. Same for langage tool.

It is installed on my LO and, I am pretty sure it was on If you click Tools > Options > Language settings > Writing Aids, is it shown with a tick under Available language modules ?

If it is for English then check that under Tools > Options > Language Settings > English Sentence Checking that you have enable the options that you want it to check.

Your document language should be set to one of the supported languages for it to work.

An expert could never understand your error message as you have not shared it; you need a clairvoyant. If you want help, then you need to give details of operating system and the error message, see This is the guide - How to use the Ask site?

1 Like

Not installed on my system, and after downloading both and attempting to install them, I get the same error message. Probably a compatibility issue. EDIT Not installed by default in Snap as well.

Thank you, Earnest Al. OS is Ubuntu 21.10. Lightproof shows loaded but not enabled. When I try to enable it, I get:
<class ‘SyntaxError’>: invalid syntax (, line 116), traceback Follows File “/usr/lib/libreoffice/program/”, line 146, in writeRegistryinfo mod =self.getModuleFromUrl( locationUrl) File “/usrc/lib/libreoffice/program/”, line 99, in getModuleFromurl codeobject = compile( src, encfile(Filename), “exec”)

The same problem exists with (1:7.2.5-0 ubuntu21.10.1. It appears that those in charge of LibreOffice are not only ignoring this concern, but are deliberately making it difficult to report this issue because they have set the software to prohibit copying of the error messages. Also Language Tool will not longer install, nor will Alt Find & Replace.

@ecigtoxdoc: your last two posts have been written as “Answers” though they aren’t solutions to your problem. This site aims at being a Question&Answers, not a forum. By using it for a conversation, you’re confusing other users who think the problem is solved. And this may refrain contributors from making useful suggestions.

To provide additional information, you can always edit your question to modify/augment it. Otherwise, use comments to briefly answer to other contributors.

Lightproof is not part of LO core. Developers bear no responsibility in its operation or not. You should channel your problem to Lightproof’s creator(s). Only them can make understanding from any cryptic message coming from their extension.

LO is doomed to evolve to cope with feature demand from users, OS evolution, standards changes, … Extension writers must keep abreast with this evolutio, not the other way round (i.e. Writer developers have no commitment towards third-party extensions).

Thank you. Perhaps you can explain the things that are happening given that:

  1. I am using a well-recognized Linux OS, and

  2. I am using the version of LibreOffice that came with the latest distribution of the OS, and

  3. No one has provided a solution to the same issue I had raised two weeks ago, and

  4. Normal adherence to quality systems requires prompt acknowledge those making inquiries.


  1. If I have encountered a known problem, it should be acknowledged and a work-around given.

  2. If I have discovered a problem, a “thank you” is in order.


  1. has powerful means to search for related bugs - for unresolved bugs and for fixed ones, too. There you also can report bugs supposed to be not yet known.
    Whom do you expect to acknowledge something here and in what way?
    If somebody can suggest a workaround may remain open for a while. All contributors here are volunteers, and I don’t know if there are many of them familiar with lightproof.
  2. Whom do you expect to return the “thank you”? What’s in disorder?
    Did you understand the way forums or Q&A sites concerning free software are working?

In my installation of LibreOffice, Ubuntu 22.04, Lightproof was not installed. I was able to install it by using info from this page:

To install:

  1. download libreoffice-lightproof-en_0.4.3+1.6-2_all.deb from Ubuntu – Package Download Selection -- libreoffice-lightproof-en_0.4.3+1.6-2_all.deb
  2. Right-click on the file, choose Open With Other Application, choose Software Install, click the install button.
  3. Restart LibreOffice.

When typing “A apple a day.” lightproof correctly flags the incorrect grammar. What’s not obvious is that the lightproof package is an extension in LibreOffice. To get to more options in lightproof, go to Tools > Extension Manager, click on the extension, then click Options.

I can only speak of Lightproof (English) when used with the Marco Pinto English Language Dictionary pack — so my comments only apply to that combination (though the same might be true of other Lightproof languages and other language dictionary packs). The situation I describe is what happens on my Windows 7 system.

When you download a new (English) version of LibreOffice then Lightproof (English) is active once that new download is installed. It is also the case that a version of the Pinto English Dictionary is installed. This combination (as supplied by LibreOffice) works fine.

However, if you manually update the Pinto English dictionaries then Lightproof (English) vanishes from LibreOffice — so you lose Lightproof (English). To recover from that situation the solution is to ‘Remove’ the Pinto dictionaries that you updated via the Extension Manager. If you do this then on a restart of LibreOffice the installed package will roll-back to the Lightproof (English) and Pinto dictionaries installed at the time you newly installed your version of LibreOffice — which, of course, would mean that you are now using and the version of the Pinto dictionaries that came with the new install of LibreOffice.

Experiment with this a bit and very carefully watch what happens in Extension Manager when you update the Pinto dictionaries to a version higher than the version that was included in the LibreOffice installer file. Also very carefully watch what happens when you force LibreOffice to roll-back to the Lightproof (English) and dictionaries installed as part of the installer package.

Basically, if you want to keep Lightproof (English) working then you should not update the Pinto dictionaries. Should also add that I don’t think this is an issue with what Marco Pinto is doing — it is a bug in LibreOffice and the Extension Manager that is causing all this to happen. The Extension Manager is knocking out Lightproof (English) if you update the English dictionaries.

This is all a known bug in LibreOffice. Details can be found here, and with a workaround that allows using the latest dictionaries: [Issue] No “English Sentence Checking” in Settings (LO)

A bug report on the issue can be seen here: Bug 140516 - Manual update English dictionary disables sentence checking.