Line spacing choice won't save

A document is double spaced. I change it to single spaced, save it, close it, reopen it, and it’s back to double spaced. This bug has persisted through multiple updates of Libre. Will it ever be fixed? Is there a workaround in the meantime?

How do you proceed? It works for me. Incidentally, OS and LO versions.

This happens on computers running both Windows 7 and 8. LO
I don’t understand what you mean by “How do you proceed?”

I mean: how do you change line spacing? You can do it “direct formatting” Format>Paragraph applying changes manually, or globally modifying a paragraph style which impacts all paras with this style. My comp is under Fedora Linux, this could explain behavior difference.

Try to use a specific paragraph style. This will force Writer to enter the settings in a persistent dictionary.

Thanks for your reply. When you advise me to “use a specific paragraph style,” do you mean by “globally modifying” rather than “direct formatting”? I’m not sure this will solve the problem because I’m quite sure I’ve never selected double spacing as a default, so that wouldn’t explain why a document reverts to double spacing after I’ve saved it single spaced. But I’m willing to try this: How do I do it?

Direct formatting is the root of all evil, try to avoid it as much as possible through the use of ad-hoc styles (think of styles as sort of semantic markup).

Comments are really too short to explain styles, even superficially. Start by displaying the styles side-pane with F11. The current style (cursor location) is highlighted. To create a new style or modify one, right-click and choose from the popup menu. Push Help button in the dialogs and read the built-in help for introduction.