link to csv file not working on second laptop

With able assistance from the forum, I have my spreadsheet working well on my 32-bit win7 laptop. I then copied it over to my 64-bit win7 laptop, and it now will not import the .csv file, it says

“The link could not be updated”

I checked (and double-checked) the link, the file is right where the link points to- in fact the file is in exactly the same place on both systems.
I tried it with both 64-bit and 32-bit calc on the laptop, no change.

The 32-bit laptop is running LO, I tried that version on the 64-bit machine, calc wouldn’t even start, so I made my way up to the current 64-bit version, trying the spreadsheet with each version, all (that would run) gave the same error.

I did a side-by-side comparison of the 2 laptops with both windows permissions and LO options to make sure they were both the same, again no change. It works on the 32-bit machine but not on the 64-bit one.

I’m using a macro that the forum helped me with

to refresh the sheet-

    REM  *****  BASIC  *****
Sub refreshAllSheetLinks()
Dim Doc As Object
Dim Sheet As Object
Dim Cell As Object   
 Doc = ThisComponent
 Sheet = Doc.Sheets(0)
    oEnum = thisComponent.SheetLinks.createEnumeration
    while oEnum.hasMoreElements
      oLink = oEnum.NextElement
      sheet.getCellByPosition(11,0). String = "Callsign"
      sheet.getCellByPosition(11,1). String = "Last Date"
      sheet.getCellByPosition(11,2). String = "& Time (UTC)"
      sheet.getCellByPosition(12,0). String = "3D2AG"
      sheet.getCellByPosition(11,4). String = "Total number"
      sheet.getCellByPosition(12,4). String = " of Contacts"
      sheet.getCellByPosition(13,4). setFormula("=COUNTA(A1:A1000000)")
      sheet.getCellByPosition(12,1). setFormula("=INDEX(dates;SUMPRODUCT(MAX((callsigns=upper(M1))*ROW(callsigns))))")
      sheet.getCellByPosition(12,2). setFormula("=INDEX(times;SUMPRODUCT(MAX((callsigns=upper(M1))*ROW(callsigns))))")
End Sub 
 Sub Main
End Sub

Again, it works perfectly on the 32 bit machine, but stubbornly refuses to read in the csv file on the 64 bit machine.

Once again, any help or suggestions would be appreciated.