LO - Writer spell check doesn't work

I recently changed to Mint 13 - Mate. When I went to use LibreOffice Writer the spell doesn’t work. A search on this site suggested there is a bug but it is fixed, deleting my profile (which didn’t work for me) and to move all the dict-xx files out of the …/share/extensions folder. I don’t have any dict file in the extensions folder! Can someone explain whether the dictionary files are meant to be a core feature or and addon (i.e. extension that will not be part of the standard install)?

Sorry, I didn’t mention my distro - Mint 13 and yes my version of LO is from the repositories.

It appears I was barking up the wrong tree. I found a post on a ubuntu site that suggest the OS language settings are related. I check Administration>Language Setting and Mint informed my I needed to download additional packages. I did this and click the ‘apply system wide’ button and spell check now works.

THANK YOU! I was going nuts. I tried a number of solutions in other “Answers”, then found this one (I’m also on LM 13). Used Synaptic Pkg Mgr, found “myspell-en-gb” package for LibreOffice, installed : WORKS! :slight_smile: Happy days.

Maybe your distro has the dictionaries in separate deb archives. Since you’re using LO, i assume you’re using the LO version from the package repositories. Because of that, i would start checking the packages installed, maybe forcing a re-install of those packages.

Thanks Colin.