LO 3.5 not recognizing java

I have got LO 3.4 installed on 64bit Kubuntu 11.10 and when I installed LO3.5 I got a series of errors during the install
javaldx: Could not find a Java Runtime Environment! (this was after each dictionary from the install archive)
On running LO3.5 Tools>Options>java shows no java. adding the same path as on my 3.4 install fails with “the folder you selected does not contain a java runtime environment”.
I entered /usr/lib/jvm/java-6-openjdk/jre which LO3.4 thinks does contain my jre. (also tried java-1.6.0-openjdk/jre and default-java/jre)
I then tried installing openjdk 7 but that did not work either.
I have tried reinstalling 3.5 and removing 3.5 (inc config) and 3.4 and reinstalling both - 3.5 first (no java) then 3.4 works fine.
At a loss of what to try next.

since found 2 other questions here, one with OSX and one with CentOS where jre is not being recognised by LO3.5

OK so who is brain dead then? I had downloaded the 386 not 64bit version of LO3.5 and installed it (but got no warning I was doing something that stupid). Just spent a long time stripping the wrong version out and installed the 64 bit version.
Now it works fine, detecting by jre just as it should.
Oddly enough there was no option available to chose between i386 and 64 bit this time around, I just got the 64 bit by default. Discovered this because I thought re-downloading it might help.