LO US English Writer: Spellcheck and Grammar not working

Version: LO, on a Windows 7. Language: US English. Component: Writer.
Hi. A few days ago, the grammar and spellcheck were just fine, and now neither is working. When I click on the “spelling and Grammar (F7)” icon, even after purposefully spelling something wrong, it says the spell check is complete. I have the “AutoSpellcheck” icon enabled, so I’ve no idea why it isn’t picking anything up. Do i just need to upgrade to the next version of Libre?

Just encountered these symptoms on a Linux Mint install of LibO 5.1. Alex’s solution wasn’t sufficient in this case. I needed to get the English Dictionaries extension mentioned in the linked Q&A (added in case the other discussion there is useful), then close LibO, and logout/restart. Then all was good. FWIW.

Hi idon’t knowwhattoputhere

There is one significant setup that can stop spellcheck from working:- LO/OO must be set for the identical language (including variant) in both the available dictionaries & setup/spellcheck.

Do the following checks:-

  1. Menu:-Tools Options... Language Settings Languages Default Languages for Documents

(make sure that this language is identical to):-

  1. Menu:-Tools Options... Language Settings Writing Aids User-defined dictionaries

(and that you have a tick in that identical language)

For me, User Interface is Default English USA, and that is the only option available. Locale + other settings as above are English UKand, until I made sure that those were all set correctly, spellcheck showed the identical symptoms that you describe.