LO 6 spellcheck is not working.

In the Options Language settings are:
Interface: English US
Locale: English Canada
Document language: French (France)
When selecting F7 spell check, the Text language is “None” Changing this is not possible. It reverts to none.

Which OS do you use?

  1. Read this tutorial.
  2. If you can’t find an answer, read these guidelines and ask a good question.

In particular, what does

Changing this is not possible.

mean? What did you do and what failed?

Normally, the language set in the system is recognized by LibreOffice. Did you choose “Typical” or “Custom” for the installation? With “Custom” you can select dictionaries. See also the example Windows:


The spell checker window merely displays the language of the text under inspection. You can’t assign a language there. (Don’t ask me why there’s a list box where you can select a language if that doesn’t have any effect.) You have to do that while editing the document, either by direct formatting (not recommended) or by modifying the language setting in the paragraph style or character style window. You can also set a default language for new documents in Default languages for documents, on the same tab where you set the interface language.

I found that the spell checker sometimes reacts oddly when it starts with no text selected - if it doesn’t find any errors, it will message that the spell check is complete, showing language as None, even when the language of the text is set to English. As soon as I enter a misspelled word, then press F7, it spots it, displays the error and updates the language box.

IMO the spell check window is a relic from the past, when computers were much slower and memory was tiny. Going through a long text with many unrecognized but correctly spelled words was a soul destroying job, and I’d every now and then by mistake accept a misspelled word after a long follow-up of correctly spelled ones. It’s useful when combined with grammar checking though.