LO Base query works under queries but not in form

I am running LO under Ubuntu 18.04.5. I have a query that involves 2 MySQL tables that populates a tablecontrol in a Form. If I run the query under Queries, it works as expected. When I use the Form, the tablecontrol does not get populated. I have checked and double checked the tablecontrol Control and Form sections, and they are correct. This Form has functioned correctly (i.e., the tablecontrol gets filled with the result of the query) for years. Now it does not. Does anyone have any idea as to why this is failing? I also should add that I have several other Forms with this type of setup, and they all fail to populate the respective tablecontrols. All other fields that are populated from MySQL tables (not queries) work as expected.


Unfortunately a question such as this only opens the door for many more questions. It would be hard to imagine this stopped working if nothing had changed. Different LO? Connector used? Was MySQL upgraded? What version is it? Using alias’s in the query? If so does one without work? Do the queries failing always involve more than one table?

Also, have you tried resetting the user profile → LibreOffice user profile

I can say for sure that the User Profile is not the problem because I started LO in safe mode and have the same problems. The release of Ubuntu is not the problem because LO ran this Base Form properly in 18.04.3. So my guess is it is related to LO My version of MySQL ran this correctly, and I always use the direct connector. MySQL is 5.7.32. Yes, the queries that fail always have more than one table.


Not certain this will answer your problem but it is all I have come up with.


      Ubuntu Release 18.04.5 LTS (Bionic Beaver) 64-bit,
      Kernel Linux 5.4.0-48-generic x86_64,
      MATE 1.20.1
      MySQL 5.7.31
      LO v6.4.x.x

Native connector for MySQL. Linked two tables together and no problem on a form. Same tables using an alias in a field (noted problem with Firebird). Still no problem on a form.

Downloaded & installed LO v6.0.7.3 and tried to run the same forms. Forgot that earlier versions had not included native connector. During the early LO v6.x series, the native connector for MySQL was included in the Linux version (not so in v6.0.7.3) and this is now a MariaDB connector. You cannot use an extension for a native MySQL connector in the latest versions. You can install but I have not gotten them to work in Linux. Before giving up on MySQL was using JDBC connection as native presented macro problems.

Had my old extensions so added:


Now ran my forms and had no problem. So only thought at this time is possibly your connector. You did not state the version used.

Above can be gotten at:




That’s an interesting thought. I checked the version and it is MySQL Connector 1.0.2. It is an extension from The Document Foundation (http://www.documentfoundation.org). I remember having to add it to get direct connect. What is driving me mad though is I have other forms with tablecontrols using queries to populate them, and the queries involve multiple tables. I am about to try deleting the object and adding it back. If that doesn’t work, I’ll delete the query, add it back, and add the tablecontrol back. Maybe this particular form has just gotten lost. But alas, I have other forms with the same problem.

Tried to use MySQL Connector 1.0.2 but was rejected as incompatible. Did have MySQL Connector 1.0.1 and that installed and worked without problem.

Have no further insight for you at this time.

Edit: My LO is 64-bit. Are you using same or is it 32-bit? Another potential for difference.

I have 64 bit as well.