LO no longer auto corrects -- to em-dash (—)

I want Writer to do so again, so anyone have a suggestion? I also can’t seem to add new replacements to AutoCorrect Options.

Does other autocorrection replacement work?

Try in this order:

  1. check if you have autocorrection enabled: ToolsAutocorrection (drop down) → While writing.
  2. Next check if ToolsAutocorrection (drop down) → Autocorrect options. Check if entries are still there, it not, you’ve messed up something with files holding autocorrection rules.

For everything else, provide LibreOffice version, operating system and language you’re using LO with.

Don’t worry. can’t be anything serious, you just disabled something by default.

I enabled the Autocorrection “while writing” option but it still doesn’t automatically replace with the em-dash. I checked Autocorrect Options and there is a list of entries present, although not the – & — replacement. And the “New” button is greyed out, so I can’t add any items.

I have a PC with Windows 10, English, and Version: (x64)
Build ID: f7f06a8f319e4b62f9bc5095aa112a65d2f3ac89
CPU threads: 2; OS: Windows 10.0; UI render: default;
Locale: en-US (en_US); Calc: