LO v4 keyboarding language does not follow OS input language

In Windows 7 and LO v3.6, when I switched the input language via the Windows hot key (or Windows language menu), LO switched the input language in Writer. This worked geat for me to be able to write in multiple languages.

Now in Windows 8 and LO v4, this does not work. (Windows 8’s switching works fine with other software, so it is not a Win8 bug.)

I have confirmed that the “Ignore system input language” option is UNchecked (in Tools Options Language Settings), so apparently that check box is not working. (LO acts like it is checked.)

XP Prof SP3 english with Asian language support
LibO 3.6.5 english us, with installed languages: English, Japanese, German and Dutch works perfectly fine.
I assume you have a problem in your OS.

Moved my comment (2013-02-21) to this answer:

That works fine for me (via Shift+Alt)
with LO 4.0.0 on WinXP (EN → EL → DE → FR → ES → ...).

@dfc – What input-languages (keyboard settings)?

I had tested successfully the “Ignore system input language” option (enabled/disabled) on WinXP in relation to the patch for fdo#36324.

Maybe, LO 4.0.0 is affected by this behavior on Win8 only.

You may open a “follow-up” bug report to fdo#36324, and add the patch contributor (J. B.) to “CC”.

@dfc – update?