LO Writer autocorrect while typing not working as expected

I’m using recently installed Ubuntu 21.04, recently I’m noting that autocorrect function is getting way worse after each newer release. While before, :<=: or any other similar after space or paragraph would automatically be replaced, but now that is only triggered with paragraph. That is opposite of what is said on latest help page or even older

It only works fine with Screen Keyboard or Virtual Keyboards, and I noticed that autocorrect function is triggered even without space or paragraph! And now it’s difficult to it even detect misspelled words without Screen Keyboard enabled (I’m not using smartphone, I’m using PC and I like Physical Keyboard…)

Version: / LibreOffice Community
Build ID: 10(Build:2)
CPU threads: 2; OS: Linux 5.11; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Ubuntu package version: 1:7.1.2~rc2-0ubuntu2
Calc: threaded

Please help, LO like this, is practically useless… Screen Keyboard takes too much space…

It works on the screen keyboard but not normal keyboard? Possibly something between keyboard and OS?

Check that:

  • In Tools > Options > Language Settings > Languages under Default Language for documents* beside Western it says English (USA)

  • Writer shows English (USA) in the bar along the bottom when you open a new document. If it says [None] then spell check won’t work, nor will AutoCorrect

  • Tools > AutoCorrect > While Typing is ticked/highlighted

  • That AutoCorrect, in Language English (USA), has the Replace With table populated with words and their shortcuts. Check your example shortcut is in there, maybe you left out an element, e.g. maybe could be :<=: for ≤

Possibly bug tdf#140445

Yes, I can confirm it works even better with Screen Keyboard active. I tried everything, nothing works… No need for Spacebar or Enter. It’d be great if that could work with Physical keyboard.