LO Writer hangs / is very slow when loading a document

Hello,

since I had to reformat my PC (I had all the data in my backup that I played on it after reformatting) and installed the new Windows version :

Edition Windows 10 Pro Version 20H2 Installed on 11/24/2020 Operating System Build 19042.685 Performance Windows Feature Experience Pack 120.2212.551.0

LO Writer is very slow when loading a document. I write my doctoral thesis with LO and usually open several documents at the same time. Sometimes the program hangs only when loading the first document, sometimes the first file opens normally and LO hangs when opening the third or fourth document.
In the end, however, the documents are always loaded, but it takes a few seconds and during this time you only see a white screen.

I have already tried the following:

  1. new installation (of both versions, 7.0.3 and 6,4.7) but did not bring anything.

So my current LO version: version is still: 7.0.3.1 (x64) Build ID: d7547858d014d4cf69878db179d326fc3483e082 CPU threads: 8; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win Locale: de-DE (de_DE); UI: de-DE Calc: threaded

  1. Whitelist Libre Office in my Ransomeware-Antivirus: Avast WEBforum - Index

At the beginning this even seemed to work, but after a few hours the problem started all over again. Even with the antivirus turned off, the files opened very slowly.

  1. Complete reset my profile, as described here: Why does LibrOffice starts so slow?

But all this did not help. Has anyone had a similar experience? I am pretty much at a loss…

Thankyou!!

  • Are your files stored on a local disk or do you use some type of a network storage (cloud service)?
  • Which file format do you use to store your documents (.odt or some other)?
  • Are you using a lot of images within your documents?
  • Have you ever tried to disable, if set, Skia in Tools -> Options -> LibreOffice -> View -> Category: Graphics Output -> Option: [ ] Use Skia for all rendering and checked whether that fixes your problem?

Thank you for the answer!!

  1. as a matter of fact I had my files in the magenta-cloud!!! So I changed the settings and now I will do the sync just when I start magenta and will not have it running the whole time! I will tell you if it works!

  2. File format is odt

  3. No, I have no images in my phd, just text (lots of footnotes though)

  4. I will try this too, thank you! If I disable skia, shall I also disable the hardware acceleration?

Thanks a lot again!!
Paba

Good morning,

so, I did some tests. Yesterday evening I stopped the the constant synchronisation in the cloud and it looked like the files opened regularly fast. When I started working this morning the problem was back again! I tried a couple of times to start LO, each time it took up to 45 sec. to open the first document! Once one document is open, the others open fast! I really don’t get this kind of behaviour… The files are all stored on my pc. They are indeed part of sync-processes (both cloud and NAS), but the synchronisatio starts only when I start the sync-program, so that should not be a problem now…

I then tried to disable skia as you suggested and restarted a couple of times (with and without hardware acceleration) but nothing, this not seem to be the issue (on the contrary, with skia disabled I experienced instability in the navigator, the different titles were somehow like blinking).

Do you have any clue by chance, what else I could try? Thanks again!!
Paba

Regarding overall time to get ready to edit - does it make a difference whether you:

  • Start LibreOffice and double click the thumbnail in Recent Documents pane on the right side –or
  • Double click a Opendocument type of file (.odt). in File Explorer to automatically start LibreOffce in one single step.

I just tried right now to first start LO and then open my document via “Recent documents” and it worked just fine!
Then I tried to reopen the document in one single step (as I used to do before) and it worked fine as well… which is strange again!
I made a restart and again: both ways work… for now!

With the many tests I did I somehow start having the feeling that after starting LO many times the opening somehow gets fast. After a long break, like in the morning, it is again slow… It is not very logical, but it already happened twice.

So, I will try both ways as you suggested tomorrow or later after a long break and will tell you if I will see a real difference.

Thank you very much!!

After a long break, like in the morning, it is again slow

Does this mean: You do not shutdown your computer every day and/or have you enabled Fast Boot in Windows?

No, sorry, I didn’t explain it well: In the evening I shut down my pc normally. But yes, I checked just now that I have the option “fast boot” enabled. Does this play a role? Should I try to turn this of?

Anyway: Yesterday evening (after a couple of hours of inactivity in LO, but PC on) and again this morning (after shutting down the pc in the night) it took both times 12 seconds to open a document in both ways, via “recent documents” and via direct clicking on the document. BUT this is the case just for the first document, after one is loaded, the others open in one second (and it doesn’t play a role whether it is a big or a small document). It is interesting that launching LO alone, withouth opening an already existing document, goes fast as well…

Fast Boot” may (I don’t say “it does”) play a role since this is not a full shutdown and re-initialization, but puts your system into a hibernation mode. Personally I don’t use this setting.

it took both times 12 seconds

And this is why you call it “very slow”? The very first load of an application always takes longer then subsequently opening additional files. Especially, if an application is as monolithic as LibreOffice is. On a first start, you need to initialize a lot of code and libraries and that takes time. From my perspective - yes, 12s is slow but it is not “very slow”. If we talk about 12s, then we really need to talk about your CPU (Type / model), your memory and the disk where your applications and operating system are located (SSD disk, SATA hard disk).

  • “Fast boot”: Thank you for the suggestion, I didn’t know about that. I disabled it yesterday, but again this morning the loading of the first LO document took about 38 sec…

  • Yes, you’re right, with 12 sec. I would be more than happy. The problem is just that sometimes it takes much more time (like this morning) and that I can’t find the cause of the problem, since before reformatting my laptop and having the new windows running, LO opened in 1/2 sec.

  • CPU: Lenovo Thinkpad X380, Intel(R) Core™ i5-8250U CPU @ 1.60GHz 1.80 GHz

  • RAM 8,00 GB

  • Disk: Samsung SSD PM981 1TB, M.2 (MZVLB1T0HALR-00000)

LO opened in 1/2 sec.

This could have been been achieved only if you had enabled option Tools -> Options -> General -> [x] Load LibreOffice during system start-up (I never saw LibreOffice or any of its predecessor up’n running from scratch that fast)

Yes, sorry, maybe it was 5 or 6 second (without having the option of loading LO during start-up), but never up to 40 seconds like it is now, which is the issue I don’t understand… If I find the cause I will write it here! Thank you again for your help!

I finally found the cause of the problem! In copying back all my datas (after re-formatting the PC) and reinstalling the MagentaCLOUD-System for Synchronisation I didn’t notice that I had the same folder twice on my pc! Since the file I wanted to open with LO was in this folder and the problem disappeard after deleting one of the two folders, I suppose this was the cause!