LO writer old files' images are flashing showing Read-Error and freezing Writer.

After few last updates, when I open older .odt files, images (both linked and inserted) in them often start flashing - rotating Read-error and inserted image. It always freezes the opened document, making it impossible to continue editing. Usually lasts for about 3-10 minutes but sometimes longer and that is starts again when I scroll to next image. Is there anything other, than hiding images from view menu, that I can do to prevent this?

It usually happens with more than 2 images on view. When there is one image, it sometimes quickly shows location, then Read-error and than inserted image.
(I have tried open one document in Open Office. It had broken links because of incorrect moving and while I was editing images’ locations, suddenly all not linked images disappeared and showed Read-Error.)

LinuxMint 17.3 64bit, LibreOffice, build ID: 1:5.0.3~rc2-0ubuntu1~trusty2
I encountered the same problem after I deleted unused macros from the file. Curiously enough, not all pictures are taking part in the rollercoaster, just the GIFs. Changing memory did not change anything.

I intermittently get the Read-Error on a pdf that I have inserted as an image. To fix it I have to right click on it and select Replace....
From petermau’s answer below, this likely is that an image is timing out from the cache after 30 minutes, AND then when the image is not being found in the cache it’s not able to correctly reload it. Humm?
I’m on Debian and LO V 5.4, but I will try V 6.2 to see if that does the same thing and report back here.

Have you adjusted the LibreOffice memory settings to take into account the number of images and text involved? TOOLS > OPTIONS > LIBREOFFICE > MEMORY. This often causes a problem…Peter


Thank you for answer, unfortunately it didn’t help. I have tried all the options there and didn’t observe any changes in writer’s behavior…

What version of LibreOffice and OS are you using?

Currently Windows 7 64 bit and LO (x64), but when I had bit older version on Windows XP, it was doing the same thing. I have tried both fresh and stable versions back then and it didn’t help.

I am facing the same problem. It is really annoying and costs a lot of time.

I was told lancecycles solution, but the menu “tools > options > load/save > memory” disappeared with the upgrade from 5 to 6 if remember correctly. In my version ( x64, windows 10) this option does not exist.

Any help is highly appreciated.