Log axes in Calc

Suppose a simple example. A range of numbers from 1e-20 to 1e-5 on both axes.

Calc will plot these correctly using log scales.

However, if I want to modify, e.g., the minimum value on the y-axis to 1e-15 it will not accept the value but takes it to be zero.

It seems any number less than 1e-10 is taken to be zero.

Using V6.4 but found same issue with V7.0.Test_axes.ods

(Ubuntu 18.04)

Can’t confirm (LibreOffice 7.0.3 and 6.4.7 on openSUSE Leap 15.2 / Version: on Ubuntu 18.04)

image description

I'd suggest you test **Safe Mode** (`Help -> Restart in Safe Mode`).

Interesting … Can you tell me how running in safe mode can help identify the issue?

I tried in LibreOffice in W-10 and indeed it is OK. When I enter, e.g., 1e-5, in one of the limit boxes, it seems to be converted to decimal form. Then, 1e-10 and smaller goes to zero.

Interesting … Can you tell me how running in safe mode can help identify the issue?

Many problems arising in LibreOffice may be caused by a corrupt user profile, especially if you are using a user profile across many upgrades of LibreOffice. Safe Mode of LibreOffice temporarily works with a fresh user profile not importing your current config (and not touching it as long as you don’t make related settings in the dialog, which appears when restarting into safe mode). If the problem does not appear in Safe Mode most likely the user profile is corrupt and resetting your user profile to factory settings will fix the problem. In that sense, you won’t identify the in-depth details of the problem (which in almost all cases of “corrupt user profile” cannot be determined at all), but you’ll get back correct functionality. And be assured: A corrupt user profile can cause problems, which you never would associate with a defect of your user profile.

I tried safe mode but it shows the same problem.

I used Synaptic to remove everything I could see that was associated with Libreoffice. I then did a fresh install of V7.0.

Still the same problem in both normal and safe mode.

So much seems to work OK. I’m at my wits end.

And you are using which PPA - this one add-apt-repository ppa:libreoffice/ppa ? or the specific 7-0 PPA? I’m going to install on my ubuntu 18.04 from PPA. if I know which one you are using.

My last install using using Synaptic which shows V7.0.3.

“About” gives:

Build ID: 00(Build:1)
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: gtk3
Locale: en-CA (en_CA.UTF-8); UI: en-US
Ubuntu package version: 1:7.0.3-0ubuntu0.18.04.1
Calc: threaded

Thanks for your help. I’m guessing there is still something corrupted that I have not succeeded in removing but I don’t know how to find it.

I’ve tested now 2 different version of on Ubuntu 18.04 and I can confirm your issue:

  1. Test: Packages from Ubuntu Launchpad PPA for LibreOffice fresh (https://launchpad.net/~libreoffice/+archive/ubuntu/ppa)
  2. Test: Packages from TDF (libreoffice.org)

Interestingly the thing works if starting LibreOffice from a terminal using command: SAL_USE_VCLPLUGIN=gen libreoffice. This means: the problem is related to the GTK3 Toolkit.

I would rate that a bug specific to the combination Ubuntu 18.04 / LibreOffice 7.0.3, but I’m not quite sure were to report that bug (could be correctly addressed to Ubuntu maintainers or to LibreOffice developers),

Great detective work and helps to restore my sanity.

A few months ago, I had been using Calc (V6.4) successfully with this same graphing structure. Recently, I had reason to return to the problem but now encountered problems with the axes. I noted that 18.04 had done a recent update, but didn’t think much about it. Instead, I thought - I’ll install V7.0 and the problem will go away.

So based on your discovery, I’m guessing the recent 18.04 update introduced the problem.

I haven’t done a bug report for either Ubuntu or LibreOffice. Do you have advice on what I should include?

For reference: tdf#138519 - Graphing, axes limits for small numbers

Opaque has nicely answered the question. Much appreciated.

Now the problem needs to be fixed …

Please do **not** use *Add Answer* if you actually don't answer a question but commenting an answer or responding to another user’s comment. Please use ***add a comment*** for that purpose. Thanks in advance …
Additionally: No bug report, no fix (and this site is not about reporting bugs).

Sorry for not following protocol. It seemed to me you had provided an answer even if the problem wasn’t fixed. Anyway, I have now submitted a bug report to LibreOffice.