Long Table pasted in Writer loses heading on several pages with Master document


I paste a long table in a Text document from a Sheet and link it is a DDE.
After that the Writer file is inserted in a master document.
The table is a long one an use several pages, to show heading in all pages I did modification in both Text and in the Master document to repeat heading with Table properties > Text flow > Repeat heading. At this stage it works and heading appears in each page.
Once I update the master document (or when a refresh when openning it) with File > Reload the heading disappears in all pages. Only the first line of the table keeps the heading.

How to keep heading always visible in all pages ?

Llibo Version: (x64) windows

Thank you

Solved: I have to change the kind of the link of the Writer document in the Master document.
Choose dde an option : Navigator > Edit Link > Link > DDE
The drawback is the Navigator will change the name of the file to ‘Text’. Doubleclick on it doesnt open the file.

Usually, a component of “Text” in the Navigator list designates the small text area separating included files. And, of course, double-clicking this “Text” component doesn’t open any file but scrolls you to it.
Furthermore, there is no reason for Writer to include a linked object in the list of subdocuments. So your issue is not related to master/subs architecture.