Loss of work

I added a column beside column A and then merged the cell and ran into the problem that all of the table is currently in the first row

Why did you delete your original question and now ask the same thing again?

I’m afraid the only option is Undo (Ctrl+Z) if the file hasn’t been saved yet.