Mac user using base: "insert image from" does not work with image control

Using the windows pc I can insert an image into an Image Control on a form using the “Insert image from” dialogue.
BUT on my MAC Pc the PC just waits for a while and then does nothing.

Is there something which needs to be done on the Mac to enable images to be added or is it a bug?

I am using LO on both a windows pc (window 10 latest) and a MAC PC (Catalina 10.15.4).

Thank you

I use the MAC PC in preference because it is quiet and fast, the windows pc is 8 years old and slower


Personally don’t use Mac but should work same as Windows or Linux (works for me). Don’t see a bug report for this so best if you submit one here → Bugzilla.

Also of note, seems you are trying to embed images. If this is an HSQLDB embedded database then you will have problems. Depending upon image size have had failure with less than 10 images. Best to use linked images.

Thank you for your assistance. I have tried linking and embedding- neither work on my Mac but both methods work on windows

Same trouble here!


Still don’t see a bug report for this. Unless you or someone files one (link in my comment above) this will remain un-resolved.

thank you Ratslinger! I solved it, relaunching the app, and everything is ok now.