MacOs Catalina Libre Office Writer will not save files

I can edit a document and print it, but when I try to save it, nothing happens. I would guess this is some kind of permission issue, because I have similar problems with Gimp, but I have no idea how to fix this.


Hi, I experienced the same…not good…but try this out it appears to do the trick.

Set Full Disk Access for LibreOffice manually in Catalina
in System Preferences,
Click Security & Privacy,
Select Privacy,
On the right click ‘Full Disk Access’,
Click on the ‘+’ to add a new application,
select LibreOffice,
Exit for settings to take effect.

If the answer worked for you please click the check icon on the left and vote the answer up.

Thank you so much, it worked.

Worked for me as well, thanks!

Thanks. Some of the files are now saving but most are crashing with this message:
LibreOffice 6.3 - Fatal Error
object is nonfunctional

Thanks for this! I signed up just so I could upvote this question and answer, but you need karma to upvote and I don’t have it. You deserve better than just this comment.

A good set of instructions. Thanks, I followed them and now I can save my files.

Yes, thanks, worked for me too (after restart of libre office)

Brilliant. Thank you so much, it worked.

Be sure to mail your spreadsheets to yourself before quitting in Catalina. They will not be saved, otherwise. This setting for Full Disk Access in System Preferences worked for me. Thank you.