(MacOS) LibreOffice 7 Crashes when trying to save a file.

Every time I try and save a 45ish MB file, LibreOffice crashes completely without saving the file. Full Disk Access has been given, and I’ve tried opening in Safe Mode. Nothing seems to work.

The save progress bar across the bottom of the screen also tends to jump or “flicker” as its saving, which usually is a sign the program will crash. Not sure what’s going on here, but any help would be appreciated.

Error dialogue attached.

(Edit: activated screenshot -AK)

Try to run LibreOffice’s “Safe Mode” (Help -> Restart in Safe Mode) and repeat the operation, which causes a crash in normal mode.

**Test** (this is **not** a solution) whether LibreOffice user profile is causing the issue:
  • Start LibreOffice
  • Restart in Safe Mode using Help -> Restart in Safe Mode and confirm the restart using button: Restart
  • Click button Continue in Safe Mode
  • Open a file causing the issue (using File -> Open) and test whether the problem is gone
  • Provide feedback using add a comment about the test result.

If the problem is gone while running in LibreOffice **Safe Mode**, most probably your user profile is corrupt and you need to reset to factory settings (could be also done via `Help -> Restart in Safe Mode`; carefully read the option in the dialog appearing when starting safe mode)

I tried this method, and the crash still happened.

Is this an Apple thing? Does Too many files error help?