MacOS libreoffice complex table document will not save spinning ball

Document with complex tables will not save on MacOS Catalina - spinning ball then just returnd to edit mode

[Edit - Opaque] removed tags will and not

When do you get the spinning ball?

  • Did you open an existing document and try to save it back, or is it new/created from blank?
  • If new, does the save dialog open first (somewhat like a Finder window, asking for name/location)?
  • Does it start when you click the save button?
  • What file type are you using?
  • What kind of storage are you saving to? Your Documents folder, iCloud or other cloud storage, removable media (USB stick etc.), or somewhere else
  • Do you know how much free space you have on your storage medium?

This was a docx document with tables to be filled that I opened with Libreoffice from an attachment to an email. I partly filled some of the tables, and I attempted to do a “Save As …” with a view to renaming it to local disc. The beach ball just spins for about 30 secs to a minute and then just goes away. I do not get the “Save as …” normal dialogue to even name the file for saving.

In desperation, I have created a new Writer document and just cut and paste the first page of tables from the original 21 page document to this document. And any attempts at “Save As…” have the same result.

Have you tried providing Full Disk Access to fixes the problem?
(How: see here - or any of the other sites found by an internet search)

Hi Opaque - Full Disk Access is already set. I use LibreOffice regularly with no problems previously.

I have been looking at what Microsoft Word could be doing to these table structures that I have been given to fill in, and I wonder about some row headings that are in the left hand cell of a row. The labels in a lot of these tables has the row label as vertical text, that is, text that is 90 degrees to the normal text flow going from bottom to the top of the row cell. My LibreOffice 6.3.3 seems to support this sort of vertical text.

Has anyone any experience is using such vertical text, particularly when the original table came from Microsoft Word? Are there subtle differences between Microsoft Word and LibreOffice handling of such a feature?

I have solved my problem.

The “Save as…” seems to fail (well, do nothing really after a short try) when a row label of the table is in vertical text format, and a word of the label wraps to a second line on that row label cell. I widened the rows so there was no word break over multiple lines and all is well.

Thanks for those who made suggestions.