Mail Merge Email Output Fails

I have been using open office for years, including latest supported version 4.1.11 and using mail merge for several clubs, doing mailings of customized account info, etc. As OO is no longer supported, and encourages changing to LO, I installed the latest version LO is obviously a derivative from Open Office and setting up the mail merge function with tried & proven documents from Open Office was simple. Setting up the email server was identical to Open Office, and the “test connection” was successful. Executing the mail merge to either disk files or to the printer produces the proper result - correctly merged documents. When then selecting email, and selecting the “to” field appropriately, identical to the process in Open Office, the screen flashes “sending emails” but nothing actually gets sent,

The email function in is clearly broken. I will be using the old Open Office app until LO is fixed.

Which operating system do you use?

1 Like

I use windows 11, and both OO 4 and LO 7 are on the same machine.


Have you assigned your mail program in Windows Settings>Apps>Standard Apps under E-Mail?

EDIT 20220217, 22.40h MEZ
Yes, sorry I use a German UI.
The translation of “Standard” in [DE] is sometimes a bit confusing.
In [EN] the translation is both correct, “Standard” = “Default”.

1 Like

you might want to consider removing your phone number from a public site (unless you like being spammed).

1 Like

There is no “standard apps” setting in my WIN11. However, there are places to assign “default apps” for various file types.

See image for the settings on my system. I asked before, but why would any “app” issue affect the mail merge, where a direct connection is made to the mail server through the server address and port number? Email for other purposes, using gmail via Brave, or webmail via outlook, etc., works just fine.

I just installed LO on an up-to-date Win10 machine with the same result. The Win10 machine also has the older OO 4.1.6 with identical setup which works fine.

I updated to x64 and the problem persists. WIll not email a mailmerge output. The email connection parameters are verified as “success”, and the screen says it is sending the emails, but nothing is actually sent.

Why advertise a capability, and have it in the menus, when it doesn’t work?


I can confirm that sending failed for me in on Windows 10. However, it worked for me in current master (toward 7.4); you might want to try a daily to check if it works for you (available at Index of /daily/master/Win-x86_64@tb77-TDF/current/).

I loaded today’s daily (April 1) (x64, Win11) and it behaved differently from before. When finally getting to the point of emailing, the program showed a box message “sending emails” and then crashed closing the libreoffice window. No email sent.

Ah, yes - I’m sorry, I forgot that is only worked after I fixed that crash. Please test tomorrow, when the daily will contain that fix.

1 Like

By the way… was the bug I reported years ago regarding Open Office’s mail merge inability to use single letter domain names fixed? Email domains such as “” were incompatible with mail merge email. A workaround was adding a space after the single letter… i.e. “q .com” which I implemented in a macro on the database. See previous bug report filed under my name.

No idea. And no "Reporter contains erikfjer" in the bug tracker, so you need to provide the report URL.

Report that to LibreOffice bug tracker, please, if it’s still repro. Then it can be handled. We do not monitor AOO bug tracker.

Code pointer: CheckMailAddress.

If and when Libre Office mailmerge email works, I will test for that one-letter domain issue.



April 2 development load worked properly for my email test. Thanks. I will try the single letter domain name to see if that is a problem with Libre Office as well (as Open Office).

Thanks for fixing the email mail merge!


I am facing the exact same issue with LibreOffice on OpenSuse Tumbleweed. Sometimes the output screen freezes, other times LibreOffice crashes. Either way, no email ever get sent.

Apparently LibreOffice 7.4 hasn’t been released yet, is there a workaround to solve this issue? It is surprising that such an old school feature would be broken in 2022, I bet they sorted it decades ago. Now this is really catching me off guard at the worst possible time.

tdf#148338 fix was backported to 7.3.3, so if you experience problems, it’s something else. And without knowing what’s your problem, there may be no solution.

Note that you may install a beta in parallel, and use it to resolve the pressing problem.

Thank you for your swift reply I am grateful for that, I have described what my problem is, which additional information should I include? As I tried to explain, I am facing the exact same issue than the original poster when following the same steps, except that the result either is a freeze or a crash in my case (random). It never works and no email is ever sent. I will check if my distro (OpenSuse Tumbleweed) has additional updates I have not installed, was it backported to or some later minor version?